cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Padmanaban
Frequent Visitor

Power BI Enterprise Gateway Fails with Unknown error

Our Enterprise Gateway fails with the error "Unknown error in Enterprise Gateway" (see below ) it is connecting to our on perm SSAS Tabular model and fails after a 30 mins to an hour of normal usage.

 

We recently installed Power BI Enterprise Gateway (moving from Power BI Analysis service connector which is now uninstalled)after which the Power BI fails with the following error "Unknown error in Enterprise Gateway" Error Code DM_GWPipeline_UnknownError, Moreover we could not see any event log for the Enterpise Gateway logged. The on prem analysis service remains functional but the gateway errors out. If we restart the analysis service server the enterpirse gateway becomes functional and Power BI works fine for 30 mins to an hour works and error repeats.Enterpise Gateway.PNG

P.S: We checked the ports and all are working fine.

1 ACCEPTED SOLUTION
nerickson
Regular Visitor

Turns out when we started using the Effective Username permission in the gateway it required the gateway service account to have Server Admin permission and not just SSAS Instance Admin permission. When we granted this permission to the server the problem appears to be ressolved.

 

View solution in original post

5 REPLIES 5
nerickson
Regular Visitor

Turns out when we started using the Effective Username permission in the gateway it required the gateway service account to have Server Admin permission and not just SSAS Instance Admin permission. When we granted this permission to the server the problem appears to be ressolved.

 

View solution in original post

ankitpatira
Community Champion
Community Champion

@Padmanaban I found below information on the error you're getting. Did you checked logs in the mentioned directory.

 

I would suggest you use this guide to troubleshoot.

 

Capture.PNG

Hey Ankitpatira,

As mentioned in the post we could not see any logs in the mentioned directory Application and Services Logs->Power BI Gateway - Enterprise Service.

Event Log.png

Hello,
You can find the Logs here: 

C:\Users\PBIEgwService\AppData\Local\Microsoft\Power BI Enterprise Gateway\EnterpriseGateway*.log

 

Please send it to hybridbi@microsoft.com so we could take a look at what's going on.
Thanks,
Dimah

 

As a temporary solution we rolled back to the Enterprise Gateway Feb release and we haven’t received the error mentioned in the past log for three days since rolling back. We followed the same installation steps each time and SSAS environment has remain unchanged.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors
Top Kudoed Authors