cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

Power BI APP throwing permission error for the first time users

Hi all,

We have developed a report and pushed to report workspace which consumes a dataset from Power BI service dataset in other workspace (dataset workspace). Then published an APP from the report workspace and auto installed for some set of users. For the same users given read access to dataset from dataset workspace(don't want to give build permissions to users). 

 

I shared the APP link with the users. They are getting the below error for the first time when they access the APP link. When they refresh the page, APP is laoding properly.

Screen Shot 2020-05-07 at 9.23.48 AM.png

What would be the reason of this behavior and what is the fix?

 

Any help is highly appreciated.

8 REPLIES 8
Highlighted
Microsoft
Microsoft

Hi @ksivaganesh99 

Are they trying to open the content from "Shared with me" or from a workspace?  

Are you sure they're opening it from "Apps"?

 

Another thought, 

Are these brand new users and this is first time they're using the Power BI service? So Power BI needs to authenticate them?

 

Let me know,

Michele

Highlighted

Hi @mihart ,

 

Thank you for the reply. I enabled auto install feature and shared the APP url directly to the end users. To your point yes they all are first time Power BI users.

 

For the first time when user opens the URL it is asking for login and post login it is throwing the error that they don't have permission (attached the screenshot in the main query). When user refresh s the page APP is rendering.

 

Any help is highly appreciated 😊

Highlighted
Microsoft
Microsoft

Hi @ksivaganesh99 ,

 

Do all users who view reports have power Bi Pro license?

For app consumers, there are two options.

  • Option 1 The workspace for this app is not in a Power BI Premium capacity: All business users need Power BI Pro licenses to view your app.
  • Option 2 The workspace for this app is in a Power BI Premium capacity: Business users without Power BI Pro licenses in your organization can view app content. However, they can't copy the reports, or create reports based on the underlying datasets

Is RLS present on the shared dataset?

Adding the user as the viewer of the workspace,they can view the report of the app.

test_rls.PNG

 

Best Regards,
Liang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted

Hi @V-lianl-msft ,

Thanks for replying. We have all the users with pro licenses. Do not have any RLS configured for the dataset. 

Do we need to add users to workspace viewers list? I do not find it anywhere in the document.

I have given access in APP permissions and read access in dataset permissions to the users.

Highlighted

Hi @ksivaganesh99 ,

 

Please try to add the user as the viewer of the workspace.

When I tested it before, there was a similar issue because of the shared dataset. When I added them as viewer role in the workspace , the issue disappeare.

 

Best Regards,
Liang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted

Hi @ksivaganesh99 ,

It's the "refresh the page" part that is confusing me. 

How are you granting permissions to the app -- did you select entire org or enter individual emails?  For the App permissions screen below, exactly how are you filling this out?

 

You write that you "enabled auto install feature and shared the APP url directly to the end users".... so you did both of these things?  Did the users experience the same problem whether they used the auto-installed version of the app AND when they used the link?

Thanks,

Michele

 

apps.png

Highlighted

Hi @mihart ,

 

"Refersh the page" means reloading the browser (browser refresh) page.

 

Permissions to APP-- Added a security group and added it to the permissions list

 

Ya I enabled "auto install" option. This is happening only when the user is clicking on the direct link.

 

Highlighted

Hi @ksivaganesh99 

I'm thinking that this is a small bug. 

IF your users can click on the app itself (you said you are setting it to auto-install), and they do not get this error and the app opens fine,

BUT your same users click on the link you send them in email/txt, they do get this error

THEN it sounds like a bug. 

 

You could search the Issues site first, to see if anyone else has reported this:.  To search the Support site and to submit a ticket, visit https://powerbi.microsoft.com/support/.

 

HTH,

Michele

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors