cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
aqavi10
Advocate I
Advocate I

Postgres database scheduled refresh issue from Power BI service

Hi,

   I am unable to refresh the report published in the Power BI service as it throws up errors. I am able to connect the Postgres database with PBI desktop and am able to refresh it from the desktop. However, after publishing it online ,it doesn't refresh

normally even after I've entered the credentials and other details.

 


Error, after setting up gateway.Error, after setting up gateway.

 

Without any gateway , refresh errorWithout any gateway , refresh error

 

 

 

Tried setting up a gateway !Tried setting up a gateway !

1 ACCEPTED SOLUTION
Greg_Deckler
Super User IV
Super User IV

Seems like you need to install Postgres drivers on a gateway in your cluster.

 

You could check the Issues forum here:

https://community.powerbi.com/t5/Issues/idb-p/Issues

And if it is not there, then you could post it.

If you have Pro account you could try to open a support ticket. If you have a Pro account it is free. Go to https://support.powerbi.com. Scroll down and click "CREATE SUPPORT TICKET".


---------------------------------------

@ me in replies or I'll lose your thread!!!

I have a NEW book! 
DAX Cookbook from Packt
Over 120 DAX Recipes!




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




View solution in original post

3 REPLIES 3
v-shex-msft
Community Support
Community Support

HI @aqavi10,

I guess you only install the Postgres driver on your device which used to design your report so that power bi not able to access to correspond datasource and refresh on power bi service side. (device who installs and manages the power bi gateway also required to access to that data source) 

If this is a case, please double check on your data gateway client, connector driver version and network policy/firewall setting to confirm if this issue is related to them.
Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.
Greg_Deckler
Super User IV
Super User IV

Seems like you need to install Postgres drivers on a gateway in your cluster.

 

You could check the Issues forum here:

https://community.powerbi.com/t5/Issues/idb-p/Issues

And if it is not there, then you could post it.

If you have Pro account you could try to open a support ticket. If you have a Pro account it is free. Go to https://support.powerbi.com. Scroll down and click "CREATE SUPPORT TICKET".


---------------------------------------

@ me in replies or I'll lose your thread!!!

I have a NEW book! 
DAX Cookbook from Packt
Over 120 DAX Recipes!




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




View solution in original post

Created a ticket through support. Thanks Greg.

Helpful resources

Announcements
User Groups Public Preview

Join us for our User Group Public Preview!

Power BI User Groups are coming! Make sure you’re among the first to know when user groups go live for public preview.

March Update

Check it Out!

Click here to read more about the March 2021 Updates!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors