cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
RandyPgh Frequent Visitor
Frequent Visitor

PostgreSQL Connection using NPGSQL gets "Scheduled Refresh has been disabled..." error

We are using the NPGSQL 3.2.7 drivers from Github to connect to PostgreSQL from Desktop and through the data gateway. The desktop version works fine, and we have worked through several gateway issues including having old Datasets in our report. Now we are getting the error "Scheduled refresh has been disabled due to at least one data source not having credentials." The one data source that is listed under the data gateway, however, tests fine. It does not show an error.

 

I am more experienced with SQL Server than with PostgreSQL, so any suggestions for debugging this would be appreciated.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: PostgreSQL Connection using NPGSQL gets "Scheduled Refresh has been disabled..." error

Hi @RandyPgh

Look at the scheduled refresh setting page, confirm an enterprise gateway is selected and the data source credential is correct.

If no abnormal is found, please delete the data source under gateway and re-connect the data source, make sure connection strings of the data source under gateway are same as that in Power BI Desktop

 

Best Regards

Maggie

2 REPLIES 2
Community Support Team
Community Support Team

Re: PostgreSQL Connection using NPGSQL gets "Scheduled Refresh has been disabled..." error

Hi @RandyPgh

Look at the scheduled refresh setting page, confirm an enterprise gateway is selected and the data source credential is correct.

If no abnormal is found, please delete the data source under gateway and re-connect the data source, make sure connection strings of the data source under gateway are same as that in Power BI Desktop

 

Best Regards

Maggie

RandyPgh Frequent Visitor
Frequent Visitor

Re: PostgreSQL Connection using NPGSQL gets "Scheduled Refresh has been disabled..." error

Thanks, maggie. There were no connection strings, but somehow dropping and recreating the data source within the gateway fixed the issue.