cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MattKarriker2
Helper II
Helper II

Paginated Report Subscriptions Go To Report button

Good afternoon forum

I am looking to understand the paginated report subscription process a little better because we are seeing issues with the "Go to Report" button the subscription is supplying.  Our paginated report uses parameters under the covers.  The users do not set these parameters themselves but rather as they navigate the parameters are set for them and the reprot renders as expected.  The paramaters are actually hidden in the paginated report purposefully so the user does not have to worry about them.  When the user subscribes to the report the parameters are being honered and the excel file produced seems to be correct.  The issue is when they click on the "Go To Report" button they receive an error because the parameters are not.  It seems no parameters are set or passed using the "Go To Report" option.  

Has anyone else experienced this behavioror know of a way to keep the parameters intact in the subscription "Go To Report" button. 

 

4 REPLIES 4
wbmarshall_IMA
Frequent Visitor

I have encountered the same issue here, but it is somewhat nuanced.  It seems we only run into this if the user clicking the 'Go To Report' button is not the report owner.  That is, user A creates a subscription for users A, B, and C.  If user A clicks the button from the email, it works as expected, but if users B or C click the button it opens up with none of the parameter selections being honored.

v-xiaotang
Community Support
Community Support

Hi @MattKarriker2 

Have you solved this problem? If yes, could you kindly accept the answer helpful as the solution (or kindly share your solution ). so the others can find it more quickly.
really appreciate!
Any question, please let me know. Looking forward to receiving your reply.

 

 

 

Best Regards,

Community Support Team _Tang

@v-xiaotang please see my post in this thread - I suspect that the original post was encountering the same issue, where the button is not working as expected only in the case where the user clicking the button is not the owner of the report/subscription.

v-xiaotang
Community Support
Community Support

Hi @MattKarriker2 

“It seems no parameters are set or passed using the ’Go To Report‘ option.  ”

-

actually, in my test, the report by using the ’Go To Report‘ option still contains parameter you set before.

here are testing steps,

vxiaotang_1-1627549023366.gif

 

Any question, please let me know. Looking forward to receiving your reply.

 

 

Best Regards,

Community Support Team _Tang

If this post helps, please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

Thank you 2022 Review

2022 Monthly Feature Releases

We had a great 2022 with a ton of feature releases to help you drive a data culture.

Top Solution Authors
Top Kudoed Authors