Showing results for 
Search instead for 
Did you mean: 

PBI Visuals not loading in Service



I am facing some issues with a PBI report which uses Direct Query. The visuals are working fine in PBI Desktop but unable to load in PBI service.


Couldn't retrieve the data for this visual. Please try again later.

Please try again later or contact support. If you contact support, please provide these details.

  • Activity ID5d7408f3-c8c6-45a2-a5d3-b7b02af3498c
  • Request IDc9f89d06-be27-747e-6044-4d0c65872bff
  • Correlation ID02626eda-6ff8-d467-ca84-9dc535dcc8c0
  • TimeWed Sep 30 2020 12:16:57 GMT-0700 (Pacific Daylight Time)
  • Service version13.0.14487.41
  • Client version2010.1.03085-train


The report also shows "There was a data source error, Please contact Gateway Administrator".


The Gateway is online and the data sources are connected as well. The Data source is conncted using service account credentials.
I have also tried republishing the report in a new workspace using a new Gateway with my user credentials but still no luck. 


Can someone please help?


Community Support
Community Support

Hi @deejag ,


For the refresh issue, there are several points you may considerate:


1.If your dataset not only contains cloud data source but also the on premise data source, then it needs to use the gateway,  and then you may configure schedule refresh, see more: :On-premises data gateway , Configure scheduled refresh .


Note that you also need to select "Allow user's cloud data sources to refresh through this gateway cluster" option Under Gateway Cluster Settings. See: Merge or append on-premises and cloud data sources.


2.Please make sure the gateway is online, and try to upgrade the gateway to latest version.


You might also need to upgrade the Power BI Desktop to the latest version version . Download the pbix file from Power BI Service, then reopen in Power BI Desktop and republish to Power BI Service.


3.Ensure that you've added one or more data sources of your dataset to the gateway, as described in Add a data source.


4.Verify that you have the correct username and password. Also, verify that those credentials can successfully connect to the data source. Make sure the account that's being used matches the authentication method.


5.Your data source credential may expire, so try to update the credential and republish the report. In Power BI, go to refresh settings for the dataset. In Manage Data Sources, select Edit credentials to update the credentials for the data source.


6.Please set schedule refresh for different datasets at different times, make sure that you don't schedule more than max parallel refreshes for the different nodes in these capacities. Also we suggest that you first disable all refreshes on all capacities. Then slowly enable the refreshes one by one. Make sure refreshes are staggered apart (e.g. 1 hour apart), and that no more than max concurrent refreshes happen at overlapping time periods.


7.there are some limitations for DirectQuery mode, see more details: Use DirectQuery in Power BI Desktop.


8.Use fiddler to monitor what happened during the refresh process.


You may resolve the issue via the troubleshooting link :Troubleshooting refresh scenarios


Best Regards,



Community Support Team _ Amy

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks everyone for your help.


The PBI Support team was able to pin down the cause.


Issue occurred due to a comment used as the last line of the SQL query- this is an ancient bug in the Analysis Services (AS) engine code, that got exposed by some recent changes in PBI Desktop.


They will fix the bug in the AS engine code, but it will probably take some time to be implemented. Till then, workaround is to either remove the comment or move it before the last line.



Helper I
Helper I

Most of our SQL-sourced datasets have failed to refresh on schedule today with this error:  Failure details: The last refresh attempt failed because of an internal service error. This is usually a transient issue. If you try again later and still see this message, contact support.

When I went in to check the gateway, I found that the Data sources included in this dataset:  were blank, but I was able to select the correct one for most of them and refresh the datasets.   One had to be re-created before it would refresh.  Our SSAS-sourced datasets were fine and refreshed as usual.  


I wonder if this is a symptom related to yours, if something changed in the service overnight?  I did notice the Teams function was released to us overnight, so I imagine other things may have changed. 


Was there any pattern to which ones of yours failed?




Thanks for your reply.


I've been facing this issue since last week - intitally thouhgt that it be be transient or a sevice error post Sept release. So, I contacted support and they have asked me to check the SQL queries which I have and those looks good to me.


This report has been in place for more than 4 years and no recent changes were made to it and there is a single datasource which is connected to the gateway via Service account.


All the other reports on the same gateway are working fine. 

Helpful resources



We are excited to announce the Power BI Super Users!

Microsoft Ignite

Microsoft Ignite with Arun Ulag

Featured Session: Drive Data Culture with Power BI- Vision, Strategy & Roadmap. Register here #MSIgnite #PowerPlatform #Power BI ​

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!


The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors