cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JWedge
Helper II
Helper II

PBI Dataset Direct Query Source missing column

Hope someone can help,

 

Connected existing report to a PBI Dataset on the service.

 

Have since updated this Dataset so that a particular table has an additional column.  Now how can I get this new column to show in the report that uses the PBI dataset as a data source?

 

So far no amount of refreshing, or republishing has worked. What am I missing? Is this a limitation??

1 ACCEPTED SOLUTION

Hi @JWedge,

 

so what sources are you combining then? A Power BI dataset Live connection and what else?

But, to my knowledge, for new columns to show up you'll have to refresh to model in Power BI Desktop and republish it to the service. They don't show up automagically unfortunately.



Did I answer your question? Mark my post as a solution!

Proud to be a Super User!


Blog: nickyvv.com | @NickyvV


View solution in original post

8 REPLIES 8
v-yuaj-msft
Community Support
Community Support

Hi @JWedge ,

 

If my understanding is correct, you originally connected to a Power BI Dataset as a data source in a live connection mode. After the data set was refreshed, a new column value should have been added but it did not appear. Is that right?

 

Best Regards,

Yuna

Hi @v-yuaj-msft thanks for replying,

 

There was already a local model in the report so my understanding is that connecting to a PBI Dataset will add it to the local model with a Direct Query connection rather than Live?

 

Hi @JWedge ,

 

Which connection mode does your local model use? Generally speaking, the following error warning will appear unless it is in live connection mode.

0202case.gifPlease refer to this link.

 

Hope that's what you were looking for.

Best Regards,

Yuna

I am using the new feature mentioned here.  So in this case it is Mixed mode.

Hi @JWedge,

 

so what sources are you combining then? A Power BI dataset Live connection and what else?

But, to my knowledge, for new columns to show up you'll have to refresh to model in Power BI Desktop and republish it to the service. They don't show up automagically unfortunately.



Did I answer your question? Mark my post as a solution!

Proud to be a Super User!


Blog: nickyvv.com | @NickyvV


View solution in original post

A bunch of other sources were already in the model (SQL, Excel, OData) before connecting to the PBI dataset. 

 

Actually may not have tried a full refresh in desktop yet as didn't need all of the imported sources refreshed and it takes a while...so will give that a go tonight 🤞(have tried publising, refreshing on the service and downloading the .pbix without luck though)

Well that did it!  Never occurred to me that refreshing all would affect the direct query connection.

JWedge
Helper II
Helper II

So I'm thinking that once the local model is set in the report it's SET and cannot be updated by the source?  Can someone confirm?

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Get Ready for Power BI Dev Camp

Microsoft named a Leader in The Forrester Wave

Microsoft received the highest score of any vendor in both the strategy and current offering categories.