cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
pvasrao Frequent Visitor
Frequent Visitor

On-premises data gateway Issue

HI All,

 

Getting the below error while sing in to power BI. Even Authentication dialog not getting to key in user id and password. Please help.

Failed to sign in. Please verify your credentials and try again. The browser based authentication dialog failed to complete. Reason: The server or proxy was not found. at Microsoft.IdentityModel.Clients.ActiveDirectory.AuthenticationContext.RunAsyncTask[T](Task`1 task) at Microsoft.PowerBI.DataMovement.EnterpriseGatewayConfigurator.AuthenticationManager.AuthenticateWithDifferentUserUsingFormsAuth()

 

Regards

Vasanth

3 REPLIES 3
Moderator v-qiuyu-msft
Moderator

Re: On-premises data gateway Issue

Hi @pvasrao,

 

According to your description, when you start on-premise data gateway and click Sign in button like below, it will not pop up a window for you to enter credential and error throws out, right?

 

a1.PNG

 

Firstly, a lot of issues can surface when the gateway version is out of date. So in your scenario, if the data gateway is installed long time ago, please update it to the newest version.

 

In addition, from the error message, it seems that the data gateway sign in automatically. Please sign out the related Power BI Service account both in Power BI Desktop and browsers. And restart the data gateway service in Service.exe. Then try to rerun the data gateway to see if you can sign in with prefer account.  

 

a2.PNG

 

Also when you click the sign in, you can use Fiddler to trace which process is broken.

 

If you have any question, please feel free to ask.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
ASHOKKPIN Regular Visitor
Regular Visitor

Re: On-premises data gateway Issue

Hi - We are trying to set up the gateway -installed the latest release on a brand new windows 2012 box. keep getting the same errror. In fact the azure sign on pops up and disappears.

 

Error is  - “The browser based authentication dialog failed to complete.”

 

I am able to see the sign on screen if i do the same thing on my desktop 

 

any ideas?

Highlighted
Super User
Super User

Re: On-premises data gateway Issue

Hi there,

 

I had a similar issue in the past when doing the installation on a server.

 

And it was due to the version of Internet Explorer on the server either being to old?

Or that due to it being a server there might be restrictions that were in place on the server. If that is the case, try and log in as Administrator, and then run Internet Explorer as Administrator also. 

 

I would suggest making sure that your IE is installed and working as expected on the server? 

 



Did I answer your question? Mark my post as a solution!

"Proud to be a Datanaut!"