cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
amir1 New Member
New Member

On Premise Gateway

Hello,

 

On premise gateway is not sarting. It started when installed but then stopped.

The error message I get is below. Please advise if there is a way to fix this. I am running it on my own laptop for now. Thanks!

 

Ensure "PbiEgwService" is running in the Services control panel

 

Gateway service health check failed.

 

Below is the stack trace:

Microsoft.PowerBI.DataMovement.Pipeline.GatewayClient.GatewayConfigurationClientException: Error getting Gateway service health data. ---> System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at net.pipe://localhost/powerbi/gatewayconfiguration/service that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details. ---> System.IO.PipeException: The pipe endpoint 'net.pipe://localhost/powerbi/gatewayconfiguration/service' could not be found on your local machine.

   --- End of inner exception stack trace ---

 

Server stack trace:

   at System.ServiceModel.Channels.PipeConnectionInitiator.GetPipeName(Uri uri, IPipeTransportFactorySettings transportFactorySettings)

   at System.ServiceModel.Channels.NamedPipeConnectionPoolRegistry.NamedPipeConnectionPool.GetPoolKey(EndpointAddress address, Uri via)

   at System.ServiceModel.Channels.CommunicationPool`2.TakeConnection(EndpointAddress address, Uri via, TimeSpan timeout, TKey& key)

   at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)

   at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)

   at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)

   at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)

   at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)

   at System.ServiceModel.Channels.ServiceChannel.CallOpenOnce.System.ServiceModel.Channels.ServiceChannel.ICallOnce.Call(ServiceChannel channel, TimeSpan timeout)

   at System.ServiceModel.Channels.ServiceChannel.CallOnceManager.CallOnce(TimeSpan timeout, CallOnceManager cascade)

   at System.ServiceModel.Channels.ServiceChannel.EnsureOpened(TimeSpan timeout)

   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)

   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)

   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

 

Exception rethrown at [0]:

   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)

   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)

   at Microsoft.PowerBI.DataMovement.Pipeline.InternalContracts.IGatewayConfigurationService.GetServiceHealth()

   at Microsoft.PowerBI.DataMovement.Pipeline.GatewayClient.GatewayConfigurationClient.GetServiceHealth()

   --- End of inner exception stack trace ---

   at Microsoft.PowerBI.DataMovement.Pipeline.GatewayClient.GatewayConfigurationClient.GetServiceHealth()

   at Microsoft.PowerBI.DataMovement.GatewayCommon.Checks.GatewayServiceCheck.RunCheck()

 

 

1 REPLY 1
Super User
Super User

Re: On Premise Gateway

That would suggest to me that the Service isn't running in the services menu on the server itself.  I've seen this happen in the past where a service has been manually disabled, or the machine has been rebooted but the service didn't come back on automatically.

 

I'd suggest logging onto the Server that runs your On Premise data gateway and go into the Services menu in the control panel.  You can also get there by going Windows Key + R -> Services.msc 

 

Just ensure that the PboEgwService is actually running:

 

Capture.PNG


   

              Did I answer your question? Mark my post as a solution!
       

Proud to be a Datanaut!