cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
biki
Helper I
Helper I

On Premise Gateway Not Configured Correctly

hello, 

 

i have searched, but not found exactly the same issue.

we have on premise gateway (enterprise version) for years, abt 2 months ago, i moved the gateway to the other server. the migration process has succeed without any trouble at all. just like voila! the connection moved to the new one.

the gateway still running well actually, but this morning, i want to stop automatic refresh process for a while due to report update, turn out that Scheduled Refresh menu is disabled, 

 

PBI GW3.PNG and i checked the gateway is not configured correctly.

 

PBI GW.PNG

 

 

 

 

 

 

 

 

 

 

but when i checked the gateway setting, its online.

 

PBI GW2.PNG   PBI GW4.PNG

 

 

 

 

 

how to configure the gateway correctly then?

pls help, thanks in advanced!

 

 

1 ACCEPTED SOLUTION
biki
Helper I
Helper I

dear all, 

 

after a week trying to solve the problem with microsoft, finally i found what was the cause.

the problem is the version of Power BI Desktop, it need to be upgraded to the latest and choose the apps from Microsoft Store, and then republish all the reports.

after that, the enterprise gateway will work smoothly.

 

i consider this problem has SOLVED then.

 

thanks to all,

biki

View solution in original post

17 REPLIES 17
biki
Helper I
Helper I

dear all, 

 

after a week trying to solve the problem with microsoft, finally i found what was the cause.

the problem is the version of Power BI Desktop, it need to be upgraded to the latest and choose the apps from Microsoft Store, and then republish all the reports.

after that, the enterprise gateway will work smoothly.

 

i consider this problem has SOLVED then.

 

thanks to all,

biki

bcteh
Frequent Visitor

To upgrade PBI desktop and republish all the reports involved alot of work!

I knew this workaround from another thread, but still, why things break in the first place?

Is microsoft going to fix it?

v-jayw-msft
Community Support
Community Support

Hi @biki ,

 

What data source you are using?

Have you checked whether the user is correctly added to the gateway?

 

Best Regards,

Jay

Community Support Team _ Jay
If this post helps, then please consider Accept it as the solution
to help the other members find it.

hi v-jayw,

 

thanks for the response.

 

i'm using sql server datasource and usually worked.

i use the administrator access so it must be has the access, right?

 

the problem is, the gateway is online and ready to use as shown below.

 

PBI GW2.PNG

 

but in the datasets setting menu, the gateway connection is "not configured correctly", how do i configure correctly then?

 

PBI GW.PNG

 

i tried to create pbi report online using the same datasource, and it's also working well. so why there's a problem anyway? and how to fix that?

 

really need a help, thanks!

 

 

If the status shows not configured it means the Drivers and Configuration for that specific data source on the Gateway ( On-Premises ) are not configured. Below are the steps I would have done to ensure its correct : 
1) Go to Machine Gateway and then try to check the connectivity to the database. If you using DSN then ensure both 32 and 64 are installed and configured. 

2) Create a sample report just connection and some drag and drop and publish the report to the power bi service. 

3) Ensure in the Gateway ( Manage Gateway of the Power BI Service ) that the user who is logged in or trying to configure the connections has the right to do so.

 

Hope this helps. 

 

Regards

Mahak

hello Mahak, 

 

thanks for the answer, i will try the steps.

 

regards,

biki

hi Mahak, below the results:

 

1) Go to Machine Gateway and then try to check the connectivity to the database. If you using DSN then ensure both 32 and 64 are installed and configured. 

-- all the machines (gateway server, powerbi desktop server) all 64bit version

 

2) Create a sample report just connection and some drag and drop and publish the report to the power bi service. 

-- first i tried to create a simple report online based on existing dataset in powerbi.microsoft.com, it's worked well.

-- and today, i tried to delete all datasource from powerbi.microsoft.com, then refresh locally via powerbi desktop and republish it again.  i also recreated the gateway connection and added all datasets but still in datasource setting, it said gateway still not configured correctly.

 

3) Ensure in the Gateway ( Manage Gateway of the Power BI Service ) that the user who is logged in or trying to configure the connections has the right to do so.

-- for all the services, desktop, gateway, i only used my account (adminstrator access) so i think there's no issue here (gateway status is online, each of dataset status is also online) 

 

maybe another suggestion, pls?

thanks for your help!

 

regards,

biki

hello,

i tried over and over to re-map the datasource.

 

biki_1-1654506187167.png

but the button Apply still disabled. as far as i remember, the button will enabled right after we pick the related database in maps combobox. is this somekind of bugs or something?

 

can anyone help me with this?

 

thanks!

regards,

biki

 

 

bcteh
Frequent Visitor

same issue here! why is this happening suddenly?

yes, it happened so suddenly. 

 

microsoft, anyone?

finally, i tried to install personal gateway and it works!

at least for now

bcteh
Frequent Visitor

but thats not the right way i supposed?

yeah, at least while waiting for the bugs fixing (if there's any).

way much better than to refresh every single report manually and then publish it, everyday.

bcteh
Frequent Visitor

but why mark it as SOLVE when this is just a temporary FIX?

we could use personal gateway as long as we need, i think. and it quite help others with the same problem. 

bcteh
Frequent Visitor

do bear in mind that personal gateway cannot auto run or "run as service". 
meaning everytime you restart the pc/server, you will need to manually sign in your personal gateway.

thanks for your info @bcteh

hopefully our server will up 247 til we find the perfect solution for this issue.

 

we're still waiting for microsoft to response (i've already open ticket for this).

Helpful resources

Announcements
September Update

Check it Out!

Click here to learn more about the September 2022 updates!

Power BI Show Episode 10 Recap

The Power BI Community Show

Watch the playback when Amit Chandak, a Power BI Super User, demos how to use Field Parameters to make reports more dynamic.

Power BI Dev Camp Session 26

New Date - Check it Out!

Mark your calendars and join us on Thursday, October 6 at 11a PDT for a great session with Ted Pattison!

Health and Life Sciences Power BI User Group

Health and Life Sciences Power BI User Group

Power BI specialists at Microsoft have created a community user group where customers in the provider, payor, pharma, health solutions, and life science industries can collaborate.

Top Solution Authors