cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jasper Frequent Visitor
Frequent Visitor

Re: On-Premesis Gateway cannot connect to MySQl source

Hi maracles,

 

When the error message occurs you can save a the log file. There I found a string that belongs to an already installed gateway and I copied it. I uninstalled all programs, deleted all files (programs, download, appdata folders). I opened start -> run -> regedit and made an export in case things went wrong. Next search I searched for the string and found an uninstall file "MsiExec.exe /X/ 2950A5B0-C59C-4738-833B-3D8E0...." I executed this file and uninstalled another instance of a gateway. I downloaded the gateway, installed the on-prem gateway (run as administrator by right clicking the file) and made a new gateway. Next I installed the personal gateway. Now it works again and hopefully it will last!

 

Good Luck, Jasper

 

Link for the regedit actions: https://powerbi.microsoft.com/en-us/blog/failure-installing-the-power-bi-personal-gateway/

 

ibarrau Established Member
Established Member

Re: On-Premesis Gateway cannot connect to MySQl source

I am having the same problem. I have an on premise gateway working with SQL Server. Then a new requirement made us connect to mysql with desktop without a problem.

When configuring gateway on Service the error for connector x64 shows up. It seems that the 64bits connector doesn't exists. So, how can Desktop recognize it and Service not.

 

Did anyone succed on this issue????? Please need an answer because personal gateway is not an option for me!!!   Smiley Sad

 

maracles Member
Member

Re: On-Premesis Gateway cannot connect to MySQl source

@ibarrau and others I have finally managed to resolve this issue with the help of Microsoft.

First, there is no specific x64 version of the MySQL connector - there is a single .net connector available that works with both x86 and x64. Some people have reported having issues with some of the newer versions however, so potentially try different version numbers.

 

Second, I've had conflicting stories on whether Personal Gateway needs to be removed however in my case it did. However, even after we had thoroughly removed personal gateway from our machine is still shows up in Power BI Service. This threw both us and the Microsoft support guys off for a little bit but to put it simply this can be ignored. The Personal Gateway will still show in Power BI Service but it isn't doing aynthing.

Regarding my specific problem, the issue was two-fold:

1. The connector was installed and being recognised by Power BI Desktop fine, however it wasn't being recognised by Power BI Service - the reason for this was that we had to restart the server with On-Premises on it.  After restarting we starting making progress, so if you have not done that please do this first.


2. When you add a MySQL data source to your On-Premises connector in Power BI you must give it EXACTLY the same name as in your PBIX file.


When you connect to MySQL in Power BI Desktop you can't actually give the source a name (as far as I know) so you end up with a name similar to 43.21.34.10;database_name this is the exact name that you have to give your source in Power BI service. So both the Name and Server field will end up being identical.

Once you have done this you should be able to connect.

A couple of things to note:


  • Sometimes even when you think everything is configured correctly you will only have the option for a database to connect using On-Premises Personal (if you once had personal installed). This for me indicated that one or more of the data sources added to On-Premises gateway had been incorrectly named. Once all of the names matche up only then did On-Premises Gateway show up as an option.
  • If you are transferring a PBIX file that was using Personal Gateway to use On-Premises gateway it will not work until ALL of the data sources are connected to On-Premises. You cannot connect if for example your MySQL connection is 100% accurate but a link to a OneDrive file is wrong.

Took a while but thankfully this is now working for us, hopefully the above helps someone.

ibarrau Established Member
Established Member

Re: On-Premesis Gateway cannot connect to MySQl source

Thank you!!! restarting the server and changing the name of the source to the exact name of the .pbix file worked!!!

Now the project is ready, thanks again.

 

Regards,

pmartin Occasional Visitor
Occasional Visitor

Re: On-Premesis Gateway cannot connect to MySQl source

I had the exact same issue and tried all the following:

  • Installing MySql Server (and rebooting).
  • Installing newer MySql drivers than 6.6.5 (and rebooting).
  • Installing older MySql drivers than 6.5.5. (and rebooting).

I could connect to the data source via a Personal Gateway and could schedule refreshes but still had an issue with the on-premises gateway.

 

The resolution was as per the comments.

  • Login to PowerBI.
  • Goto your Gateway.
  • Add a new datasource.
  • Ensure that the datasource name is "server;database", i.e. "10.0.100.1;reports"
  • Fill in all the other fields.

Thanks

 

anilreddy128 Frequent Visitor
Frequent Visitor

Re: On-Premesis Gateway cannot connect to MySQl source

I used above suggestions and Now I am getting into another issue related to SSL.

 

"An error happened while reading data from the provider: 'A call to SSPI failed, see inner exception.'". 

 

I was able to solve this in Power BI Desktop by unchecking a check box in datasource settings. But I could not find a way to do this on gatway.