cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jpquinn
Helper I
Helper I

On-Premesis Data Gateway - Upgrading - The communication object...in the Faulted state.

I just opened the On-prem gatway and clicked hte link that said I had an update. I clicked, installed, and was signing in my my ID as I'm the admin, and then when to sign in to Restore the existing gateway, and I get the below error when I select the existing gateway and key in the recovery key.

 

The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state.

 

What can I do to resolved this quickly?

 

1 ACCEPTED SOLUTION

Update: Fix  - For my issue, the fix was to change the accout being used within the Logon tab on the service itself. I'm not sure what it was exactly, "NT SERVICE\PBIEgwService", but I change it to an account that also is a proxy account, and presto, it worked. Not sure how the other account worked at all until I did this upgrade, or even why I must change it to this due to upgrade. I've upgraded a few months ago and did not have this fiasco.

View solution in original post

5 REPLIES 5
bystarlight
Regular Visitor

I'm having the same issue. Solutions mentioned already (changing Log On account and running as admin) aren't working for me.

 

Any other solutions????

I typically find for me after an upgrade of the gateway, it will always change the username and password that run at the Services, so I go there and replace with the proper username/password, which is our Proxy one we use for other things as well like for SSIS, and other items that run off jobs that need automated sign on. Go to Services, go to On Pre Data Gateway service, right click, properties, logon tab, go from there. Document this before and after.

jpquinn
Helper I
Helper I

I also get this error:

 

rror generating an asymmetric key.
The profile for the user is a temporary profile.

 

 

I've uninstall the gateway and then reinstalled and when trying to recover the existing gateway, I get the same errors as mentioned previously.

 

I also get this error: Gateway service health check failed.

 

I go to this website and I've tried what seems to apply to no avail

 

 

Update: Fix  - For my issue, the fix was to change the accout being used within the Logon tab on the service itself. I'm not sure what it was exactly, "NT SERVICE\PBIEgwService", but I change it to an account that also is a proxy account, and presto, it worked. Not sure how the other account worked at all until I did this upgrade, or even why I must change it to this due to upgrade. I've upgraded a few months ago and did not have this fiasco.

View solution in original post

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

July 2021 Update 768x460.png

Check it out!

Click here to read more about the July 2021 Updates