Showing results for 
Search instead for 
Did you mean: 
Frequent Visitor

OData or sharepoint list oAuth2 authentication not working

Hi All,


I have various dashboards running on scheduled refresh up in the power BI service which have one of their data sources as OData connection from our O365 SharePoint sites / lists.


These connections work fine in desktop and have been working fine in the Power BI Service up until yesterday, but now will not authenticate when trying to set the data source credentials as part of a scheduled data refresh. I have tried the same sites with the SharePoint (get data) connection and get the same issue in the service, although like the Odata connections works fine when using Power BI Desktop.


For those we had already set up as scheduled refreshes have all failed now due invalid credentials on the odata connections, however we are unable to set them due to the above and no changes have been made to make them invalid in the first place.

The Credentials are correct, they work in the desktop no problem and I sign in no problem in the Power BI Service and our Office 365 SP sites using the same credentials.


We have tested this with a few users on our tenant and all getting the same issue.


Anyone else getting this issue / Know how to solve it please?


Any help would be greatly appreciated.


Kind Regards Ste


We are getting the below erros.


Failed to update data source credentials.
Activity ID:b1fc828f-e391-901b-49b5-9c19c846373f.
Request ID:0d09bf28-9485-b061-9db5-d59614c79304.
Status Code: 500
Version: 13.0.1500.472

Your data source can't be refreshed because thecredentials are invalid. Please update your credentials and try again.Your data source can't be queried because the credentials are not provided. Please provide your credentials and try again.

Activity ID:b1fc828f-e391-901b-49b5-9c19c846373f

Request ID:e9fbcf52-3137-e6de-8a29-4a19172b12b7
Status Code: 20
Version: 13.0.1500.472
New Member

I stumbled on this thread today while researching what sounds like a similar issue.


As with others on this thread, things had been working as expected for us over the last few weeks/months, but we're now suddenly experiencing this issue. MFA was enbled for our users 20 days ago, and several users are now reporting encountering this.   


We opened a Premier Support case and have passed along the information contained in this thread. Our Support Engineer suggested that we update Power BU Desktop, uninstall/re-install the Gateway, and ultimately took a Fiddler trace. While he's analyzing the collected data, we're going to try to add to our Trusted Sites (can't do so locally due to Group Policies), then whitelist IP ranges for this and the various regional clusters (e.g.,


Please let us know if you receive any updates on your collective cases and we'll do the same.     

Hey, y'all! Here's an update:


After reading the OP, my gut feeling was that our issue was probably related to the implementation of the MFA in our environment - and a subsequent Fiddler trace seem to support it. After digging a bit deeper, we determined that MFA was enabled the day before the users began having these issues - not 20 days prior as I was originally told. That news practically made it a certainty that an authentication issue was the culprit.


After bringing this up to the support engineer, he gave us the following eleven IP ranges which cover all of the 329 (and more) clusters: 




The O365 admin added these ranges and confirmed that OAuth2 was working as expected. The IP ranges were subsequently and we were able to repro the error again. The error definitely appears to be related to an extra step in authentication while trying to reaching a resource within the eleven whitelisted IP ranges we were provided.


I'll submit an update once we narrow the issue down further, and if y'all will do the same, I'd appreciate it.



Hi @StephenMatthew,


Thanks for the details, I'll let you know as soon as we hear anything to.


I have updated our call to let them know you have also logged one.


Cheers Ste

Advocate I
Advocate I



If you are using Internet Explorer, add this site to your trusted sites.



-- in the IE Internet Options, Security, Trusted Sites


Internet Options.JPG

It solved the problem for me.


Frequent Visitor

Hi @bfrancis


Tried this and unfortunately it didn't work.  The Premier support engineer I have been delaying has took a fiddler trace and is escalating it to the product group.


Will update when I have more info.


Regards Ste

Regular Visitor

Hi Ste, 


Did you manage to get a resolution from the support engineer? More info is appreciated.


Best Regards,

Frequent Visitor

Hi @sanean


The call is still open, its now been escalated to the SP team from the Power BI team, as soon as I have more info i will let you know. As a work around I have logged in external to our network to set the credentials which allows the refresh to work no problem and the service remembers the credentials so unless there is a change no need to set again.


Regards Ste

Frequent Visitor

Extract from premier update as of 24/10/16:


"It is been a long time since I updated you. The SharePoint team was investigating this issue. They have informed me, it requires further investigation and possible escalation to the product team.  "


Will keep you all posted as i know more.

Frequent Visitor

I'm having the exact same issue. I connected to my OneDrive Excel sheet using the following method:


This has worked for me for months (and continues to work with my Power BI Desktop files). However, this week the files are not refreshing online because they say my login credentials are invalid. Nothing has changed on my end though. My username and password are the same, and I haven't uploaded any new desktop files.




I have't reproduced your issue. When I "Edit Credentials" successfully in DataSet setting, it prompts the web page for entering credential if I select OAuth type to sign in. 






Hi @v-sihou-msft,


Thanks for the update, apologies for the delayed response I have been on holiday the past two weeks. 


I am still getting the issue, that being said I think I have narrowed down where the issue may be.


The issue seems to only occur when I am trying to set the credentials from on-prem (within my AD environment), when I am not on my corporate network it seems to work.


We have MFA (Multi Factory Authentication) set up for our O365 but when within our internal AD environment, we are white listed (Our network IP range is) so it does not prompt for our second factory. When using Power BI service external to our network I am prompted for my Second factory Auth when setting the credentials and this works fine.


Connecting to all other O365 services from on prem work fine (without having to be prompted for the second factory) they also work externally, with being prompted.


We do remember that in the past we had an issue similar to this and the problem was caused when we moved from ADFS 2.0 to 3.0 and we lost the setting for having Forms Authentication set in our authentication polices. However, we have now checked this now we have narrowed down the issue and the issue is still persistent even tho forms authentication is set on.

We have logged this with our Premier support contact we have here now, so will let you know what they say too.


@mwinkels not sure if this helps you or if you have MFA, it might be the same issue?


We see exactly the same issue as @SteHext.


I can confirm that connecting to an external network and signing in using MFA is a workarround for this issue.

Helpful resources

Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!