Reply
Regular Visitor
Posts: 42
Registered: ‎04-23-2016
Accepted Solution

Not allowing me to select use data gateway after dataset change

 

I had a service running and refreshing nightly . I made a dataset change and republished it now it will not refresh and although my on premise gateway is running the  "Use Data Gateway" option is grey and unselectable. I deleted the entire set and republished confirmed that my data sources are configured and connected but this Use Data Gateway option is not open to be selected. 

 

Any Ideas ? 

 

Thanks 

 

 


Accepted Solutions
Regular Visitor
Posts: 42
Registered: ‎04-23-2016

Re: Not allowing me to select use data gateway after dataset change

Thank you for your reply this is all great information. Late last night I found my issue.

 

One of my data sources is an on premise shared drive, the exact path mapping between my file location on the desktop application and the data source in the PBI service did'nt match as my PC drive mapping started above the root node and my the path of my data source on the BI service was the full path.

 

Example :   My location on the desktop was  \node2\node3\file.xls (because the mapped drive pointed directly to node 2).

                  The data source on the service side was defined \\Node1\node2\node3\file.xls

 

I change the path via edit data soruces on the desktop app, republished and was able to use the on premise gateway.

 

I am going to suggest that they present an error log or message when data sources from a dataset are not found as a datasources in PBI service.  

View solution in original post


All Replies
Highlighted
Moderator
Posts: 9,878
Registered: ‎03-10-2016

Re: Not allowing me to select use data gateway after dataset change

[ Edited ]

Hi @brett_walton,

Could you please describe more details about that what changes you made in your dataset?

The issue that the "Use Data Gateway" option is grey could be caused by that you combine multiple data sources in a dataset, but you don’t add each data source under the on-premises gateway. If that is the case, please ensure that you add each data source under the gateway and then check if the "Use Data Gateway" option is available.

In addition, please note that on-premises  gateway doesn’t work with online data sources currently, thus if you combine on-premises data source and online data source in a dataset, you are not able to use on-premises gateway to schedule refresh for the dataset. In this scenario, you can use the personal gateway to schedule refresh for your dataset.


Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Regular Visitor
Posts: 42
Registered: ‎04-23-2016

Re: Not allowing me to select use data gateway after dataset change

Thank you for your reply this is all great information. Late last night I found my issue.

 

One of my data sources is an on premise shared drive, the exact path mapping between my file location on the desktop application and the data source in the PBI service did'nt match as my PC drive mapping started above the root node and my the path of my data source on the BI service was the full path.

 

Example :   My location on the desktop was  \node2\node3\file.xls (because the mapped drive pointed directly to node 2).

                  The data source on the service side was defined \\Node1\node2\node3\file.xls

 

I change the path via edit data soruces on the desktop app, republished and was able to use the on premise gateway.

 

I am going to suggest that they present an error log or message when data sources from a dataset are not found as a datasources in PBI service.