cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

No longer able to connect to any SQL server database or refresh data

Up to a few hours ago, Power BI was working fine. I am in an unusual situation in that I don't have Admin credentials on my laptop or at my organization and therefore cannot run the app as administrator, nor can I uninstall and reinstall Power BI Desktop.  I did try a repair and a reset, didn't resolve. I have the latest November 2020 Desktop (2.87.684.0 64-bit), installed today but I don't know when and there is no proof the updated version is the cause of the connection errors I'm seeing.

 

Error below appears at each attempt to refresh existing data on 4 reports with different SQL server connections or at any new SQL connection.  Excel, Access, XML connections are fine but the data I use resides on varous SQL servers.  I do have the right credentials - user and roles - on the SQL servers and can, of course, do anything on that side but would not want to make server changes unless there is no other way.  I was trying out some different connection strings JUST BEFORE the first instance of this error appeared.  I believe it was a failed attempt to connect to SQL Server Analysis Services Databases that was my undoing - I should not have tried, we don't have an on premise gateway. Momentary lapse of judgement.  All research points to a .NET mismatch or a corrupted local use profile.  Any feedback on where to start to resolve this would be most welcome.  Thanks!

Exception.PNG

1 ACCEPTED SOLUTION

Going back to Oct 2020 version fixed the issue (for now...)
You can uninstall Nov 2020 version and then install this: https://download.microsoft.com/download/8/8/0/880BCA75-79DD-466A-927D-1ABF1F5454B0/PBIDesktopSetup-2...

View solution in original post

4 REPLIES 4
Frequent Visitor

Thanks for the heads up! I though I was the only one having this issue. In my case, they migrated the server as well and I was thinking that might be the issue, but when I could connecting using apps, I knew there was a problem with the Power BI update.

Regular Visitor

As of today, I am having the same error.  However, I am able to run as an admin. This started happening after I got the November 2020 update.  

Going back to Oct 2020 version fixed the issue (for now...)
You can uninstall Nov 2020 version and then install this: https://download.microsoft.com/download/8/8/0/880BCA75-79DD-466A-927D-1ABF1F5454B0/PBIDesktopSetup-2...

View solution in original post

New Member

We are also having the same error here.  We recently updated to the November 2020 version.  Users on October 2020 version do not have this issue.  We tried running with local admin privs but that didn't help.

Helpful resources

Announcements
secondImage

Congratulations!

We are excited to announce the Power BI Super Users!

Wave Release 2

Check out the updates in Power BI.

Overview of Power BI 2020 release wave 2!

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors