cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

New measure not appearing in power bi services data set

Hi,

 

I created a new measure in my report. After I publish it in Power BI Services, the column does not appear in the dataset causing my visual to have an error.  I tried to remove the dataset first, then publish it again, that's the time the new measure appeared. Do I need to remove the data set and publish it again every time I will add a new measure?

 

 

Thanks in advance 🙂

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: New measure not appearing in power bi services data set

Hi @cess02,

 

Based on my test, we needn't t publish the report twice. In your scenario, please follow below steps to troubleshoot the issue:

 

1. Before you publish the report, make sure the report in desktop is saved and there is no error in visuals.

2. Please use the latest desktop version 2.44.4675.422.

3. In Power BI service, use Get Data -> Local Files to publish the report.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: New measure not appearing in power bi services data set

Hi @cess02,

 

Based on my test, we needn't t publish the report twice. In your scenario, please follow below steps to troubleshoot the issue:

 

1. Before you publish the report, make sure the report in desktop is saved and there is no error in visuals.

2. Please use the latest desktop version 2.44.4675.422.

3. In Power BI service, use Get Data -> Local Files to publish the report.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Frequent Visitor

Re: New measure not appearing in power bi services data set

Hi @v-qiuyu-msft

 

It works! Thank you very much 🙂

Highlighted
Helper I
Helper I

Re: New measure not appearing in power bi services data set

@v-qiuyu-msft  @cess02 
Hi 

I have exactly the same problem , but I'm not sure to understand the solution. Where can I find the "Get data" ni pbi service ?

 

Thanks for your help. 

 

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Upcoming Events

Upcoming Events

Wondering what events you could join or have an event to promote yourself? Check out our Upcoming Events.

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

We are thrilled to announce we will begin running a monthly webinar series named Power BI Dev Camp.