Reply
Frequent Visitor
Posts: 3
Registered: ‎11-11-2016
Accepted Solution

Need to have Do Not Summarize on Values

Hello,

I know there have been previous posts on this topic, but I am yet to find a solution to this problem. Most of the data that I need to use in Power BI reports, I can not aggregate or summarize into a Sum/Average/Max/Min/etc. I require to show the data as it is found.

Please! Can someone show how to report data values with out changing the value to a Sum/Average etc, in Service and Desktop??  In my Desktop version, the Modeling tab, the default summariztion option is not active, so I am unable to select any option there.

 

Please tell me how I can show actual data numbers with out summarizing into a Sum/Average/etc modification.

 

CE


Accepted Solutions
Frequent Visitor
Posts: 3
Registered: ‎11-11-2016

Re: Need to have Do Not Summarize on Values

I attended a Power BI workshop seminar here in town last week, and was able to discover the solution of setting the default summarization to Don't summarize. 

So, that seems to be resolve my problem. 

 

Thanks for your time and help. 

 

View solution in original post


All Replies
Super User
Posts: 3,484
Registered: ‎06-25-2015

Re: Need to have Do Not Summarize on Values

@ceveland You have this option for any numeric field in the visual itself when you are creating the reports. The default behavior is going to summarize, so you need to specify this each time (from my understanding). When you add the field to the values section you click on the down arrow to the right of the field name and select "Don't Summarize"

dontsummarize.png

Near SE WI? Join our PUG MSBIWI
Moderator
Posts: 2,588
Registered: ‎03-06-2016

Re: Need to have Do Not Summarize on Values

@ceveland

 

As you mentioned, you default summarization is greyed out. Right?

 

What's your data source? Did you use import mode or direct query? Please verify the data type of the data field, it must be numeric. If it's already numeric fields, the default aggregaion type supposes to be set in data source, like SSAS with live connection. Otherwise you have to set the summarization on visual level like @Seth_C_Bauer suggested.

 

Also see a similar thread bleow:

https://community.powerbi.com/t5/Desktop/Default-Summarization/td-p/20726

 

Regards,

Frequent Visitor
Posts: 3
Registered: ‎11-11-2016

Re: Need to have Do Not Summarize on Values

The problem is that I do not ever get that Don't Summarize option when trying to build a report. 

Moderator
Posts: 2,588
Registered: ‎03-06-2016

Re: Need to have Do Not Summarize on Values

@ceveland

 

I think you are using "Connect Live" mode. Then you should check the data type in your source. Make sure it's not numeric type so that it will not be aggregated.

 

Regards,

Frequent Visitor
Posts: 3
Registered: ‎11-11-2016

Re: Need to have Do Not Summarize on Values

I attended a Power BI workshop seminar here in town last week, and was able to discover the solution of setting the default summarization to Don't summarize. 

So, that seems to be resolve my problem. 

 

Thanks for your time and help. 

 

Regular Visitor
Posts: 16
Registered: ‎03-13-2017

Re: Need to have Do Not Summarize on Values

Could you expand on " was able to discover the solution of setting the default summarization to Don't summarize".   How is that done globally?  Or, are you talking about changing them one-by-one?

 

I have many numeric categorical variables that PowerBI wants to sum by default when I import data.  How can I set the default so no variables are set to "Sum" as the Default Summarization.  PowerBI gets many more wrong than right when I import data.

Established Member
Posts: 267
Registered: ‎02-01-2018

Re: Need to have Do Not Summarize on Values

@Seth_C_Bauer- this is not the case with the usage of a Matric visual if I am not wrong? That is something that is needed.
Frequent Visitor
Posts: 10
Registered: ‎07-26-2016

Re: Need to have Do Not Summarize on Values

This does not resolve the problem in my case.  I am pulling project data from MS Project.   I pull the "percent work completed" field.  It's default is a decimal number.  Whether I have the default of "Do not Summarize" checked, or whether I change this field to a percentage or a whole number, it does not give me the option to "do not summarize"

 
See below for a video

 https://www.dropbox.com/s/mx67w108o7573ur/2019-01-28%2015-24-36.flv?dl=0