cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate II
Advocate II

Navigation builder - Link in content area gives error "refused to connect"

I have created a new link in navigation bulder, which is supposed to open in content area. When I open the link in app, I get error "refused to connect" and in upper left corner, I find another error message saying "This widget contains web content not provided by Microsoft. Web content could contain code with security or privacy risks."

 

I have tested this with several browsers and also our customer tested this with same result. If I change the link to open in same tab, it works, but that is not the good way of using it.

4 REPLIES 4
Highlighted
Community Support
Community Support

Re: Navigation builder - Link in content area gives error "refused to connect"

HI @MiraNi ,

As document said, current power bi not support to third party url. It will display security notice when you use third party link in it:

Publish an app in Power BI#considerations for using the new navigation builder option

A security warning is shown at the top of the embedded content to indicate the content isn't in Power BI.

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.
Highlighted
Advocate II
Advocate II

Re: Navigation builder - Link in content area gives error "refused to connect"

I understand, it will show the security warning in left upper corner but it doesn't display the web page at all but gives the error message "xxxx refused to connect". I have tried with internal O365 -page, https://app.powerbi.com as it offers this link as a default and other web page. I only manage to get them open when having open in tab option.

Highlighted
Frequent Visitor

Re: Navigation builder - Link in content area gives error "refused to connect"

Exactly the same issue here...

Highlighted
Regular Visitor

Re: Navigation builder - Link in content area gives error "refused to connect"

I have the same issue.  I want a PDF on a sharepoint to show in the content area rather than in the current or a new tab.  I know it is possible because Veolia have done it with an impressive demonstration as shown at a Power BI event by @AmirNetz  - https://www.youtube.com/watch?v=daQt9jp4kxA (skip to 1:02.00 for the showcase and notice the 'Tutorial' and 'Documentation' parts.

What I currently get is my PDF appears for 1-2 seconds and then disappears but hovering the mouse over the grey content area gives a 'tooltip' of my document file name, so Power BI is recognising that it is there but not showing it.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Come join us today! Find your favorite faces from the community presenting at the Power Platform Community Conference!

Upcoming Events

Experience what’s next for Power BI

See the latest Power BI innovations, updates, and demos from the Microsoft Business Applications Launch Event.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Mark your calendars and join us for our next Power BI Dev Camp!.

Top Solution Authors