cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
don_Kamillo Frequent Visitor
Frequent Visitor

Nav Content Pack - cannot conntect to data

I created NavUserPassword type user, added SSL to oData service and everything tutorials told me to. 

I am able to log to oData URL and see data behind in a browser. Everything is ok then. 

When I try to add application "Nav Content Pack" in PowerBI - I get error with response status 400 and info: The credentials provided for the OData source are invalid.

 

What should I check?

2 REPLIES 2
Moderator v-qiuyu-msft
Moderator

Re: Nav Content Pack - cannot conntect to data

Hi @don_Kamillo,

 

Please check if below facts: 

 

1. The account you are using doesn't have permissions to retrieve the Microsoft Dynamics NAV data from your account. Verify it is an admin account and try again.
2. The Dynamics NAV instance you're trying to connect to doesn't have a valid SSL certificate. In this case you'll see a more detailed error message ("unable to establish trusted SSL relationship"). Note that self-signed certs are not supported.

 

Best Regards,
Qiuyun Yu 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
brent_CWS New Member
New Member

Re: Nav Content Pack - cannot conntect to data

I'm having the same issue. I confirmed with my IT department that I have an admin account. I'm able to view the XML result from the OData URL in a browser (after entering my credentials in the prompt), but when I try it through Power BI it is saying that my credentials are invalid. Any help is much appreciated.