cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ab Frequent Visitor
Frequent Visitor

NAV Content Pack - Cant connect

Hi,

 

I have a problem connecting to the Power BI - NAV Content Pack.

Each time I try to log on with window authenication, I get the following error message. 

Power BI NAV Content Pack error.JPG

 

What I have been trying to do beside checking that my Odata url is working:

 

  • Install On-premise Gateway (Personal)

However this did not do anything. (maybe im missing something here?)  

 

  • I have tried to follow the following manual with no luck.

https://powerbi.microsoft.com/en-us/documentation/powerbi-content-pack-microsoft-dynamics-nav/

 

  • Install fiddler to track message

I just recieve a http status 400. 

 

  • Power BI Desktop

This work, can easily conntect to Power BI Desktop

 

  • Install On-Premise Gateway

Can also setup a On-premise gateway which I can use to update my data source created from Power Bi desktop. 

 

 

Currently im trying from Navision 2016 CU 3 with the following setup:

Power BI NAV Content Pack error 3.JPG

Power BI NAV Content Pack error 2.JPG

 

The following setup has worked before (4-6 months ago), but now I have to demonstrate this to a new customer but cant get the content pack to work.

 

I really cannot see what i am missing here. I think its my personal gateway, but not sure how I can configure it further than the options its already promping me when I am installing it.

Last time I installed the personal gateway (4-6 months ago) I belived I had to type my windows credentials but this isnt case anymore. Now I only have to type my Work mail, atleast im not sure where to configure my window credentials for the personal gateway? 

 

I already read the following about gateways:

https://powerbi.microsoft.com/en-us/documentation/powerbi-personal-gateway/

https://powerbi.microsoft.com/en-us/documentation/powerbi-gateway-personal-mode/

 

Thanks in advance,

ab

 

EDIT

I stumble upon the following topic https://community.powerbi.com/t5/Integrations-with-Files-and/NAV-2016-NAV-Content-Pack-Won-t-Install...

 

What do they mean by Dynamics NAV Online?

Does this mean I have to host my Navision somewhere in the cloud with azure? 

 

1 ACCEPTED SOLUTION

Accepted Solutions
ab Frequent Visitor
Frequent Visitor

Re: NAV Content Pack - Cant connect

OK. Found the solution..

 

NAV instance should had been Credential type; NavUserPassword

4 REPLIES 4
Community Support Team
Community Support Team

Re: NAV Content Pack - Cant connect

@ab

 

Hi ab, 

 

The Microsoft Dynamics NAV content pack in the Service is an on-line service. So no gateway is needed here. Please check these things below:

1. The URL format should like this: https//instance.navserver.com:7048/DynamicsNAV90_Instance1/OData/Company('CRONUS%20International%20L...

2. "Make sure the URL is in 'https'." So SSL is needed.

 

 

Best Regards!

Dale 

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
ab Frequent Visitor
Frequent Visitor

Re: NAV Content Pack - Cant connect


@v-jiascu-msft wrote:

@ab

 

Hi ab, 

 

The Microsoft Dynamics NAV content pack in the Service is an on-line service. So no gateway is needed here. Please check these things below:

1. The URL format should like this: https//instance.navserver.com:7048/DynamicsNAV90_Instance1/OData/Company('CRONUS%20International%20L...

2. "Make sure the URL is in 'https'." So SSL is needed.

 

 

Best Regards!

Dale 


Hi Dave,

 

Thanks for your reply. 

 

I already tried another service with a SSL Certificate and I get the same result and I have also verified the link look alike the one you sent.

From fiddler I get: HTTP/1.1 400 Bad Request

 

However the only different is that this NAV Instance use "Basic Authentication". 

Also with this service (The service with SSL), I cannot use the Odata service in Power BI Desktop. 

Here I get HTTP/1.1 401 Unauthorized from Fiddler.

 

However the odata link works fine in a browser. 

Not sure why i get the HTTP/1.1 401 Unauthorized, because the credentials work in a browser and Navision.

Also tried with and without Domain, e.g. Domain\UserName or just Username. 

 

Not sure what my Credentials are supposed to be here? 

 

But thats why i tried testing a NAV Odata service which use Crendential Type "Window" which seems to work in Power BI Desktop.

 

But I am not sure how I can proceed from here?

 

Again Thanks in advance,

Ab. 

 

 

EDIT:

I use to follow this link to get my Power Bi working:

http://thinkaboutit.be/2015/12/connecting-the-power-bi-dynamics-nav-content-package-to-a-local-nav-2...

 

But with the new Personal gateway I really dont have the option with windows credentials?

and as Dave pointed out it shouldnt be neccesary anyway. 

 

If you are interested I can post the response from Fiddler, but as I have stated earlier i get the HTTP/1.1 400 Bad Request

ab Frequent Visitor
Frequent Visitor

Re: NAV Content Pack - Cant connect


@v-jiascu-msft wrote:

@ab

 

Hi ab, 

 

The Microsoft Dynamics NAV content pack in the Service is an on-line service. So no gateway is needed here. Please check these things below:

1. The URL format should like this: https//instance.navserver.com:7048/DynamicsNAV90_Instance1/OData/Company('CRONUS%20International%20L...

2. "Make sure the URL is in 'https'." So SSL is needed.

 

 

Best Regards!

Dale 


 

Hi Dave,

 

Thanks for your reply.

 

I already tried with a NAV instance with SSL Certificate but I just end up with the same error as above.

However, if I try to connect to Power BI desktop, with the NAV instance with SSL,  I get HTTP status 401, authentication invalid. 

But the Odata links works fine in browsers. 

 

I use to follow the following link to get the NAV content pack to work before. 

http://thinkaboutit.be/2015/12/connecting-the-power-bi-dynamics-nav-content-package-to-a-local-nav-2...

But as Dave pointed out, a gateway shouldnt be neccessary. 

 

If you like I can post my Fiddler response if that might help.

Again, not sure what I am missing here. 

 

Also, not sure if this is related hower but, if I install the Personal gateway, I cannot find it under Datasource schedule. 

Should I not be able to update a datasource with my personal gateway? It is not showing up. 

 

EDIT

With NAV Instance with SSL certificate I use UserName as Credential Type. 

 

ab Frequent Visitor
Frequent Visitor

Re: NAV Content Pack - Cant connect

OK. Found the solution..

 

NAV instance should had been Credential type; NavUserPassword