cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jkingry Frequent Visitor
Frequent Visitor

Migrated from on-prem AD to Azure and nothing works right anymore!

I have a customer who has a Power BI infrastructure in a Power account called admin@theirdomain.com.  A week ago all of their AD accounts were migrated from on-premise to Azure, the data refresh for their admin account immediately started failing.  So I log into that admin@theirdomain.com account and go into the EDW workspace and there is no place to actually store a dataset.   Additionally I click manage gateways and nothing ever happens, no pop ups, failures, or screen change.  The reports and dashboards still work fine though and still retrieve data from a dataset even though I can no longer see any datasets or a place for datasets.

 

 

PowerBIFirstError.png

 

So I have opened a ticket with Microsoft, they initially told me to redeploy the dataset and wanted me to run a Fiddler trace of me clicking manage gateways.  So I run the trace, I am still hesitant of redeploying any projects, so I send the trace to MS and wait, they come back and tell me to re-install the gateway.  So I uninstall the gateway from the server as it had not been updated for months and installed the latest version and set it up with a new gateway.

 

I go into Power BI and create a new workspace, deploy the project to the new workspace, and configure the gateway.  Everything works in the new workspace.  I then go into the old “production” workspace and click manage gateway there and once again nothing happens.  So finally I try to re-deploy the project to the workspace and get a “Sorry you don’t have access to publish to this workspace.  Please contact the owner for access”

 

PowerBIFinalError.png

 

So that is when it hits me.  Power BI is treating the old on-prem admin account object ownership different than the new Azure admin account.  So the EDW workspace is owned by the old user account and the new one cannot see the datasets or overwrite them or manage gateways from the old domain etc.  So my question is……. And I asked Microsoft support this question.  Is there any way for me or Microsoft to change ownership of the workspace and force it to the new account so we do not lose all the reports and dashboards that have been created in this workspace?

4 REPLIES 4
Super User
Super User

Re: Migrated from on-prem AD to Azure and nothing works right anymore!

When you say "migrated to Azure" do you mean that you created cloud-only accounts in Azure AD and did not use Azure AD Connect?


I have book! Learn Power BI from Packt


Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!

Community Support Team
Community Support Team

Re: Migrated from on-prem AD to Azure and nothing works right anymore!

Hi @jkingry,

 

I try to search for related information but failed, since power bi groups are host on office 365, you can try to use administrator account to edit the original group at admin portal.

 

Reference link:

Manage Group membership in the Office 365 admin center

 

In addition, since your issue is more related migrate on-premise ad to azure ad, I'd like to recommend you post this issue to azure AD forum for further support.

 

Regards,

XIaoxin Sheng

Community Support Team _ Xiaoxin Sheng
If this post helps, please consider Accept it as the solution to help the other members find it more quickly
Learning resources: Power BI
jkingry Frequent Visitor
Frequent Visitor

Re: Migrated from on-prem AD to Azure and nothing works right anymore!

Thanks for the replys everyone.  Here is the latest:

 

I was able to get to my datasets, I talked to the AD resource and they performed an AD sync.  We added that power bi account in question as an AD admin and were able to see everything again and the "manage gateways" function is working now too.

 

So I went into "manage gateways" and created a new datasource for the new gateway Microsoft had me install.  That connects and is working fine. 

Powerbi3.png

 

 

So with that success I go to my dataset and try to schedule a refresh but I never see the gateways to select I only see two spinning circles like it is trying to refresh.  I have left it for a couple hours and it is still spinning?

Powerbi4.png

 

I am really lost here as to why I am getting this erratic behavior.

Community Support Team
Community Support Team

Re: Migrated from on-prem AD to Azure and nothing works right anymore!

HI @jkingry,

 

Since it is hard to reproduce your issue, perhaps you can use fiddler to trace the detail operation informations and report these logs and sessions to power bi team to get further support.

 

Fiddler Trace

Fiddler is a free tool from Telerik that monitors HTTP traffic.  You can see the back and forth with the Power BI service from the client machine. This may show errors and other related information.

 

Reference link:

Troubleshooting the On-Premises Data Gateway

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin Sheng
If this post helps, please consider Accept it as the solution to help the other members find it more quickly
Learning resources: Power BI

Helpful resources

Announcements
New Topics Started Badges Coming

New Topics Started Badges Coming

We're releasing new versions of the badge that everyone's talking about. ;) Check your inbox for notifications.

MBAS 2020

Save the new date (and location)!

Our business applications community is growing—so we needed a different venue, resulting in a new date and location. See you there!

Difinity Conference

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)