cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DBBenny
Regular Visitor

Matrix not showing data after dataset refresh

Hi,

 

I'm new to the forum so I will do my best to describe my issue but I might forget some key info so don't hesitate to ask.

 

I created a report containing a matrix (see images "Before refresh In Power Bi Desktop" and "Before refresh in Power Bi Online"). The data of the matrix is also used in a table on an other page (see image "Table with same data as the matrix").

 

Here is the issue : when I run the ruport in Power Bi Desktop, everything works fine. When I publish it on powerBi.com, it still works fine, but as soon as the dataset gets refreshed, the matrix is showing empty. I know that the data is there because we can see it in the other page.

 

At first, I thought that it might have something to do with filters, but why would it show data before the refresh and also in PowerBi desktop. I tried the "Reset filters, slicers and other data view changes you've made" button, but its not changing anything.

 

Any thoughts?

 

Thx for your help.

 

David

Before refresh in Power BI DesktopBefore refresh in Power BI DesktopTable with same data as matrixTable with same data as matrixBefore refresh in Power Bi OnlineBefore refresh in Power Bi OnlineAfter refresh in Power Bi OnlineAfter refresh in Power Bi Online

2 ACCEPTED SOLUTIONS

Thank you @RicoZhou. It seems that I don't have the latest version installed. I will try this and let you know if it helps.

 

Talk to you soon !

 

David

View solution in original post

Hey @RicoZhou, it turns out that my problem was not related to my power Bi version, though the latest version is way faster so thx for the hint ! 🙂

 

Fortunately, I read the thread that you suggested and I found the answer in @Wouter 's post (‎2017-10-18 06:57 AM) https://community.powerbi.com/t5/Issues/Visualization-BLANK-after-refreshing-page-in-Power-BI-servic...

 

I was using Boolean in the filter for this particular visual and PowerBi service changed it into 0/-1 during the refresh. The solution => to convert the boolean into text in powerquery and to filter based on text.

 

Thanks a lot for your help, and special thanks to Wouter 🙂

 

Cheers !

 

David

View solution in original post

5 REPLIES 5
Nimai123
Post Patron
Post Patron

Hello @DBBenny 

 

There may be an issue with the Date column as the Power BI service is not able to fetch it and Desktop is able to, you will get a clear and step by step explanation in the below blog, hope you replicate it and helps you.

 

https://www.pbiusergroup.com/communities/community-home/digestviewer/viewthread?GroupId=547&MessageK...

 

IF YOU LIKE MY ANSWER PLEASE GIVE KUDOS AND IF MY ABOVE POST HELPS YOU TO SOLVE YOUR PROBLEM ACCEPT IT AS A SOLUTION. 

Hi @Nimai123,

 

Thanks for you response. I have looked at this post and compared my data from Bi Desktop and BI Online, but everithing is fine, the date formats are normal (there are some in text, but my date table has de date format yyyy-mm-dd). Also, I already know that the data is fine since I show the detailed rows into a table on another page. I guess that if there would be a problem with some dates, I'd have at least some numbers here and there in my matrix, but its completly empty.

 

It has to be something else.. Anything else you think of ? 

 

Thanks again.

 

David

RicoZhou
Community Support
Community Support

Hi @DBBenny 

Please check the version of your Desktop, if it is not the latest version, please upgrad it to the latest one.

I found an issue: Visualization BLANK after refreshing page in Power BI service like yours, hope it could help you solve your problem.

 

Best Regards,

Rico Zhou

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly. 

Thank you @RicoZhou. It seems that I don't have the latest version installed. I will try this and let you know if it helps.

 

Talk to you soon !

 

David

View solution in original post

Hey @RicoZhou, it turns out that my problem was not related to my power Bi version, though the latest version is way faster so thx for the hint ! 🙂

 

Fortunately, I read the thread that you suggested and I found the answer in @Wouter 's post (‎2017-10-18 06:57 AM) https://community.powerbi.com/t5/Issues/Visualization-BLANK-after-refreshing-page-in-Power-BI-servic...

 

I was using Boolean in the filter for this particular visual and PowerBi service changed it into 0/-1 during the refresh. The solution => to convert the boolean into text in powerquery and to filter based on text.

 

Thanks a lot for your help, and special thanks to Wouter 🙂

 

Cheers !

 

David

View solution in original post

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

April Update

Check it Out!

Click here to read more about the April 2021 Updates!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

secondImage

Experience what’s next for Power BI

See the latest Power BI innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors