Reply
Frequent Visitor
Posts: 11
Registered: ‎07-24-2018

Mapbox not displaying in App. (Works fine in Desktop and Workspace)

Hi

 

I have a Mapbox visual on a Power BI report. 

 

Works fine on Desktop

Works fine in the service when published to a workspace

Works fine if sharing the report directly from the workspace

However, when the report is published and viewed in an App, the visual is just blank grey.

 

Does anyone know why? Screenshots below.

 

Have checked both Edge and Chrome. Same thing.

 

Can confirm browser supports WebGL https://get.webgl.org/

 

Mapbox App.jpgMapbox Workspace.jpg

Community Support Team
Posts: 1,986
Registered: ‎07-10-2018

Re: Mapbox not displaying in App. (Works fine in Desktop and Workspace)

Hi @Farhan75,

 

Based on my test using the Power BI desktop  version: 2.64.5285.461 64-bit (November 2018). I canot reproduce your issue here. Did you use the latest version of desktop?

 

mapbox.PNG

 

Regards,

Frank

Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Frequent Visitor
Posts: 11
Registered: ‎07-24-2018

Re: Mapbox not displaying in App. (Works fine in Desktop and Workspace)

Hi Frank

 

Thanks for the reply. Yes, using latest version.

Version: 2.64.5285.701 64-bit (November 2018)

 

The issue we are experiencing is not on desktop, but when viewing the report in a published App (if that helps). Visual works fine in Desktop and in Workspace.

 

Thanks

 

Farhan

Highlighted
Member
Posts: 91
Registered: ‎02-12-2017

Re: Mapbox not displaying in App. (Works fine in Desktop and Workspace)

In case you don't find resolution here, you might want to try on their Github repo:

https://github.com/mapbox/mapboxgl-powerbi