cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
burgesst Frequent Visitor
Frequent Visitor

Login stuck in a loop - reports appear briefly then go blank

I go to powerbi.microsoft.com and click 'sign in'. I enter my work email and password.  My dashboard shows for half a second, then goes to a screen saying 'We know you! You’re using xxx@xxx.com with another Microsoft service already. To finish signing up for Microsoft Power BI, sign in with your existing password.

 

I click 'sign in' and get another login screen. I enter my email, and as soon as I tab out of the box, it says "It looks like xxx@xxx.com is being used with more than one account. Which account do you want to use?". Work or school account, or personal account. I pick work account. I enter my password again.

 

It says "No need to sign up. You already have a license for Microsoft Power BI." I click "OK, got it".

 

My dashboard appears again for half a second, then goes to "preparing power BI" with a progress bar. The dashboard appears yet again for half a second, the the preparing screen goes through a second time.

 

Then I go to a blank white screen, and nothing further happens!

 

What on earth is going on, and how do I fix this ???

 

 

 

3 REPLIES 3
v-haibl-msft Super Contributor
Super Contributor

Re: Login stuck in a loop - reports appear briefly then go blank

@burgesst

 

Since you can sign in successfully, it seems that there is no problem with your account. Which browser did you use? How about the result if you change to other browsers? And if you have no success in office, you can have a try in other network environments like at home to see if it works.

 

Best Regards,

Herbert

burgesst Frequent Visitor
Frequent Visitor

Re: Login stuck in a loop - reports appear briefly then go blank

Hi, I have tried Chrome, IE and Firefox, and also the Power BI mobile app - all the same.

 

I have tried it at work and from home - still the same.

 

BUT I have just tried again, and it's all working! That's the first time in months!  The only thing that happened was another admin turned off my Power BI Pro trial as it had expired, but that expired weeks after this problem first occurred.

 

So I'm glad it's working, but frustrated that I don't know what it was, as if it happens to our users, I still won't know how to fix it!

 

Thanks

 

 

Highlighted
v-haibl-msft Super Contributor
Super Contributor

Re: Login stuck in a loop - reports appear briefly then go blank

@burgesst

 

Not sure if the expired pro trial is the root cause. But you can let the admin do the same thing if it happens to your users. And if it cannot be fixed, you can post again here to ask for help.

 

Best Regards,

Herbert

Helpful resources

Announcements
Ask Amir Anything

Exclusive LIVE Community Event No. 2 – Ask Amir Anything

Next in our Triple A series: Ask Amir Netz questions about the latest updates, features and future.

Ask Amanda Anything Q&A

Ask Amanda Anything Q&A

Learn the answers to some of the questions asked during the Amanda Triple A event.

October 2019 Community Highlights

October 2019 Community Highlights

October was a busy month in the community. Read the recap article to learn about some of the events and content.

New Solution Badges

New Solution Badges

Two waves of brand new solution badges are coming! Read the article for more information on our new community badges.

Top Kudoed Authors
Users Online
Currently online: 517 members 5,148 guests
Please welcome our newest community members: