cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
pnopbi
Frequent Visitor

Log Analytics option for the Workspace - Disappeared

Yesterday I set up Log Analytics to a workspace and it worked like a charm.

I understand the feature is in preview.

Today it vanished as in the option is not even listed on the workspace.

yes, I checked and all the requirements are present: Workspace-level Log Analytics permissions (preview) is checked; the owner permission to the log analytics workspace to the pbi user and the 'microsoft.insights' resource provider is registered in the Azure portal for the  subscribtion.

It has not been disconnected and it does not even show for the Workspace setting in the Azure connections. I mean, there is only the Storage option no Log Analytics.

 

what gives?

2 ACCEPTED SOLUTIONS
GilbertQ
Super User II
Super User II

Hi @pnopbi 

 

Can you check with your Power BI Admin if they have disabled the setting in the tenant settings?

 

Here you can see my settings below

 

GilbertQ_0-1627595649268.png

 





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

View solution in original post

pnopbi
Frequent Visitor

hey @GilbertQ ... so I went back to the Admin Portal and unchecked and checked the Azure Connections \ Workspace-level Log Analytics permissions (preview)  and it is now visible again! I didn't even save anything after unchecking and checking...
go figure!

thanks for your tip!

View solution in original post

4 REPLIES 4
GilbertQ
Super User II
Super User II

Hi @pnopbi 

 

Awesome glad to help!





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

GilbertQ
Super User II
Super User II

Hi @pnopbi 

 

Can you check with your Power BI Admin if they have disabled the setting in the tenant settings?

 

Here you can see my settings below

 

GilbertQ_0-1627595649268.png

 





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

View solution in original post

pnopbi
Frequent Visitor

hey @GilbertQ ... so I went back to the Admin Portal and unchecked and checked the Azure Connections \ Workspace-level Log Analytics permissions (preview)  and it is now visible again! I didn't even save anything after unchecking and checking...
go figure!

thanks for your tip!

View solution in original post

pnopbi
Frequent Visitor

yep, same as the tenant settings in this tenant. thanks

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Get Ready for Power BI Dev Camp

Microsoft named a Leader in The Forrester Wave

Microsoft received the highest score of any vendor in both the strategy and current offering categories.

Get Ready for Power BI Dev Camp

Power BI Dev Camp - September 30th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.