cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dherre90 Frequent Visitor
Frequent Visitor

KPI goal disappears only after publishing workspace

Hi there,

 

I've made some KPI visuals which are connected to weekly goals. There's a "weekly transactions" table which outputs transactions together with the week starting date, and a "weekly transaction targets" table, which has the targets and the corresponding starting dates of the weeks. When I create the visual in Power BI desktop it works perfectly; it nicely shows a trend for the past few weeks, the latest transaction amount and the corresponding transaction target. This also works when I publish the report to the web service, and other people can see it as well. 

 

But then, when I publish the workspace as an app, the goals suddenly disappear. Both in the published app as well as in the app workspace the goals in the KPIs now show "goal blank, % infinity". I've tested it over and over again, but as long as I don't publish the app it keeps working, and afterwards it stops. Am I encountering a bug? Or is there some "feature" in publishing apps which causes this? 

 

Thanks for your help.

1 ACCEPTED SOLUTION

Accepted Solutions
dherre90 Frequent Visitor
Frequent Visitor

Re: KPI goal disappears only after publishing workspace

I don't know what exactly is going on, but I got it working. 

 

Everytime, it was working fine on Desktop, and after uploading on Service it still worked. But after publishing the "infinity" goal started to appear. 

 

After endlessly checking and rebuilding relationships between the tables, setting the correct data type and format etc., I tried to manually change the data format (like in the raw data input) from 01-01-2018 to 2018-01-01. After that change, it keps working after publishing. This is very weird, because the raw data was always the same formatted in both tables and I edited the data types and formatting during the modelling in Power BI Desktop. Apparently there's something Desktop can handle that Service can't. 

 

Anyways, it works now. 

3 REPLIES 3
Community Support Team
Community Support Team

Re: KPI goal disappears only after publishing workspace

Hi

I haven't reproduced your issue.

9.png

What's your data source? What's the data type and format of that date column in your source.

Does any RLS applied in the data?

Can you share some screenshots?

 

Best Regards

Maggie

dherre90 Frequent Visitor
Frequent Visitor

Re: KPI goal disappears only after publishing workspace

Hi, thanks for your response.

 

My data source is a Redshift database through an ODBC connector. 

 

The tables look like this:

 

image.png

 

Both week_start fields are of data type date, and formatted exactly the same (dddd d MMMM yyyy). There is no RLS applied anywhere.

 

When I create the report in Power BI Desktop, everything works perfectly. When I upload it to the service, it works perfectly. But then later, when I publish the app, the goals sometimes turn into "infinity", and sometimes not immediately, but then they do when I log in later. It's the same for other viewers of the report in the workspace and viewers of the app.

dherre90 Frequent Visitor
Frequent Visitor

Re: KPI goal disappears only after publishing workspace

I don't know what exactly is going on, but I got it working. 

 

Everytime, it was working fine on Desktop, and after uploading on Service it still worked. But after publishing the "infinity" goal started to appear. 

 

After endlessly checking and rebuilding relationships between the tables, setting the correct data type and format etc., I tried to manually change the data format (like in the raw data input) from 01-01-2018 to 2018-01-01. After that change, it keps working after publishing. This is very weird, because the raw data was always the same formatted in both tables and I edited the data types and formatting during the modelling in Power BI Desktop. Apparently there's something Desktop can handle that Service can't. 

 

Anyways, it works now.