Showing results for 
Search instead for 
Did you mean: 
New Member

Javascript API GetReports and Getreport don't return Description field



Everything is on the title.

I am calling PBI Embedded API from web application deployed on Azure App Services and I cannot retrieve Description field on a report. I've tested it on both APIs getreports and getreport.


Is there a mismatch between API and its documentation that referring to this field ?


All permissions seem to be provided as written in the note :  "A Power BI report. Below is a list of properties that may be returned for a report. Only a subset of the properties will be returned depending on the API called, the caller permissions and the availability of the data in the Power BI database."


Any help appreciated




Helper I
Helper I

I am facing the same issue.  I tried retrieving the description from a report I own using my regular account.  I also tried as a tenant admin.  The field is not even returned as part of the result.




New Member

Hello Yalan,


Could you be more precised on which permissions I should change ?

For a test, I've already set "admin" permission to service principal that is acessing API, I don't see other user or option ?


Thank you.



Community Support
Community Support

Hi, @aloire ;

I think you could check the credentials and whether you have sufficient permissions.

Best Regards,
Community Support Team_ Yalan Wu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Kudoed Authors