cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate II
Advocate II

Issue with multiple SSAS cubes (the visual has unrecognized fields)

We have a SSAS MD database with multiple cubes.

An enterprise gateway is installed and configured. The account is a SSAS server admin.

 

We created a test report in Power BI Desktop on one of the cubes and published it to the Power BI service. Everything works as expected. Then I created another report in Power BI Desktop, on one of the other cubes. Published it succesfully to the service.

 

However, this time not everything works. Measures or dimensions unique to the second cube are not displayed. If I add them to a visual, I get a big cross with the message "The visual has unrecognized fields". But, if I use a conformed dimension which is also in the first cube, it does work. The field list displays all of the metadata, but Power BI can't display the  data unique to that cube.

 

When I monitor with profiler, nothing arrives at the cube. If I use a shared dimension, the query does arrive and is processed correctly. The query is addressed to the correct cube.

 

It seems like Power BI is messing up to the models (since shared stuff works), but when I use something that works, the query is sent to the correct cube.

 

Any ideas?

Blog: sqlkover.com
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Microsoft
Microsoft

Re: Issue with multiple SSAS cubes (the visual has unrecognized fields)

The fix for this issue has been deployed to production (should have arrived ~mid-June).

 

If you are still having problems with this issue please let us know, so that we can find out if the issue has regressed again since then or if the fix did not cover your particular scenario.

View solution in original post

14 REPLIES 14
Highlighted
Advocate II
Advocate II

Re: Issue with multiple SSAS cubes (the visual has unrecognized fields)

Update: when monitoring the gateway server with fiddler, the JSON response to a non-working dimension had the following error:

 

Could not resolve model references in the Semantic Query. Affected items: [dimension name].

Blog: sqlkover.com
Highlighted
Advocate II
Advocate II

Re: Issue with multiple SSAS cubes (the visual has unrecognized fields)

OK, so I tried again this morning, after the weekend, and suddenly everything of the second cube works. Without any intervention. However, now some visualizations from the first cube - who did work - are now not working. Weird.

Blog: sqlkover.com
Highlighted
Microsoft
Microsoft

Re: Issue with multiple SSAS cubes (the visual has unrecognized fields)

Thanks for raising this issue @koenverbeeck, we have looked into it and identified a caching issue in the PowerBI service for cases where there are multiple cubes for the same database.

 

A bug has been filed for the feature team. In the meantime, unfortunately there are not any workarounds we can suggest for the problem other than waiting 10-15min for the cache to clear in the service before opening the report.

 

Highlighted
Advocate II
Advocate II

Re: Issue with multiple SSAS cubes (the visual has unrecognized fields)

OK, thanks for the feedback!

Blog: sqlkover.com
Highlighted
Helper II
Helper II

Re: Issue with multiple SSAS cubes (the visual has unrecognized fields)

I' suffering the same issue.

my first cube in my OLAP database is working fine, the second one has the same error.

and I suffer this problem with both an OLAP and Tabular instance on my server.

 

Highlighted
Advocate II
Advocate II

Re: Issue with multiple SSAS cubes (the visual has unrecognized fields)

What's the status on this issue?

Blog: sqlkover.com
Highlighted
Microsoft
Microsoft

Re: Issue with multiple SSAS cubes (the visual has unrecognized fields)

The fix for this issue has been deployed to production (should have arrived ~mid-June).

 

If you are still having problems with this issue please let us know, so that we can find out if the issue has regressed again since then or if the fix did not cover your particular scenario.

View solution in original post

Highlighted
Advocate II
Advocate II

Re: Issue with multiple SSAS cubes (the visual has unrecognized fields)

Hi,

 

somehow I completely missed your reply.

I just checked and everything seems to be working.

 

Thanks for the fantastic support!

Blog: sqlkover.com
Highlighted
Frequent Visitor

Re: Issue with multiple SSAS cubes (the visual has unrecognized fields)

This is happening to me, I'm not hittting cubes tho. 

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Upcoming Events

Upcoming Events

Wondering what events you could join or have an event to promote yourself? Check out our Upcoming Events.

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

We are thrilled to announce we will begin running a monthly webinar series named Power BI Dev Camp.

Top Kudoed Authors