cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ashishrj
Power Participant
Power Participant

Issue with Matrix visual when published online

Hi Microsoft team,

There seems to be some issue with displaying matrix visual when published online. Error screen as shown below. Same can be correctly seen in desktop tool. Kindly help us fix this. Same is been observed for few other reports as well. Thank you.

 

ashishrj_0-1639630541686.png

 

1 ACCEPTED SOLUTION
v-janeyg-msft
Community Support
Community Support

Hi, @ashishrj 

 

This issue has been submitted internally. Internal ICM ID:275902988 about 'Couldn't load data for this visual'. Will have to wait for the fix on PBI Feb version. Please be patient to wait for fixing. If there is any news, I will update it here.
 
Best Regards,
Community Support Team _ Janey

View solution in original post

5 REPLIES 5
v-janeyg-msft
Community Support
Community Support

Hi, @ashishrj 

 

This issue has been submitted internally. Internal ICM ID:275902988 about 'Couldn't load data for this visual'. Will have to wait for the fix on PBI Feb version. Please be patient to wait for fixing. If there is any news, I will update it here.
 
Best Regards,
Community Support Team _ Janey

Thank you @v-janeyg-msft for your swift response. I have recreated the matrix from scratch and it worked but could not really do that for all the reports (from 40+ reports this was encountered in 3 reports so far but haven't checked all the reports). Also, I have connected to Microsoft support team and still they are trying to figure out the root cause. I have no other choice but to wait.

v-janeyg-msft
Community Support
Community Support

Hi, @ashishrj 

 

After searching, I found that there are similar issues with different solutions.

I want to ask some questions to judge:

  • What's your data source?
  • What's your connection mode?
  • Do you use a gateway?

  • In addition to the matrix visual, are there other visuals that have this error?

Here are similar solved threads for reference:

Solved: Couldn't load the data for this visual - Microsoft Power BI Community

Solved: Couldn't load the data for this visual - Microsoft Power BI Community

Solved: Error: Couldn't retrieve data for this visual. Pl... - Microsoft Power BI Community

 

I also found that there is a same icm issue: 279243614 that solves the problem by rebuilding the matrix visual.

 

Did I answer your question ? Please mark my reply as solution. Thank you very much.
If not, please feel free to ask me.

 

Best Regards,
Community Support Team _ Janey

 

mtomlins
New Member

I am seeing the same issues with Matrix tables in the service.

This report has been working fine for months.
Changing to a table populates the data fine.

 

Keen to hear any suggestions.

ashishrj
Power Participant
Power Participant

Tagging few folks for faster response

@Ying @pying @yingyinr @v-stephen-msft @RicoZhou @v-janeyg-msft 

Helpful resources

Announcements
November 2022 Update

Check it Out!

Click here to read more about the November 2022 updates!

Difinity Conference

Difinity Conference 2022

Difinity is the largest Microsoft Data, AI, Power BI, Power Platform and Business Applications Conference in New Zealand.

European Share Point Conference

European Share Point Conference

This conference returns live and in-person in Copenhagen this 28 November-01 December with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Microsoft 365 Conference â__ December 6-8, 2022

Microsoft 365 Conference - 06-08 December

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Top Solution Authors