cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Issue with Gateway On Premises

Hello all, 

 

Is anyone able to help, I was previously able to publish reports to our workspace from the PowerBI desktop and share this report with members of team, with members able to access the report. However, after publishing a recent report, and trying to access the report via the web application, a no gateway error message appeared Screenshot 2021-06-18 at 17.03.23.png

 

However, gateway on premise was never installed and there are no personal gateways, but we are unable to untick this as it has been greyed out 

Screenshot 2021-06-18 at 16.57.25.png

 

Any help on how to navigate this will be appreciated!

 

Thanks

6 REPLIES 6
v-janeyg-msft
Community Support
Community Support

@Anonymous 

 

Have you tried to install the gateway and configure the refresh? Any questions?

ashanthakumar
Helper II
Helper II

Hi,

 

    Is the recent report refreshed in the desktop ?.

 

Thanks,

Shanthakumar

Anonymous
Not applicable

Hi @ashanthakumar ,

 

Yes the report is refreshed in the desktop version and works perfectly, the issue appears to be once published to the web version

v-janeyg-msft
Community Support
Community Support

Hi, @Anonymous 

 

What type of data source and connection mode are used for the latest report you publish? If you can't connect to the data without a gateway, this problem may occur.

 

You can go to the dateset>>setting to view the refresh history and see what is wrong with it.

If it doesn't solve your problem, Please share more datails and feel free to ask me.

 

Best Regards

Janey Guo

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Anonymous
Not applicable

Hi @v-janeyg-msft,

 

Thanks for your response, the data sources used are a combination of excel sheets and data from sql server, and using DirectQuery to connect to the SQL database. 

 

The issue is there is no gateway, but we have never had a gateway set up previously, and the reports used to work before, but now none of the reports are working

Hi, @Anonymous 

 

You use the DQ mode to connect to the database, which must use the gateway to get the data.

I don't know why you can run the report without a gateway before, because unless you use cloud data, you can refresh as long as you add credentials. Even if you use the import mode, the local data needs a gateway to refresh. Unless you don't refresh.

You can learn and download from the link below, then configure the gateway.

On-premises data gateway - Power BI | Microsoft Docs

 

Best Regards

Janey Guo

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

Thank you 2022 Review

2022 Monthly Feature Releases

We had a great 2022 with a ton of feature releases to help you drive a data culture.

Top Solution Authors
Top Kudoed Authors