cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Issue With Scheduled Refreshes/Gateway Suddenly Stopping Working

I'm looking for some help with gateways. The PBI scheduled refreshes at my company suddenly stopped working overnight, from what I can tell, the error has something to do with the gateway. Unfortunately, everyone who was involved in setting up the gateway is now gone, so I'm at a loss as to what to do. We use On Premises gateway in personal mode that shows it is online and ready to be used, and we connect to a SQL Server. Also, when I refresh one of the reports in PBI Desktop, it refreshes fine with no issues, and the query editor doesn't show any errors. MS support has not responded to my ticket.

Any advice would be greatly appreciated.

Error:
Something went wrong
There was an error when processing the data in the dataset. Please try again later or contact support. If you contact support, please provide these details. Data source error{"error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","pbi.error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","parameters":{},"details":[{"code":"DM_ErrorDetailNameCode_UnderlyingErrorCode","detail":{"type":1,"value":"-2147467259"}},{"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"The key didn't match any rows in the table."}},{"code":"DM_ErrorDetailNameCode_UnderlyingHResult","detail":{"type":1,"value":"-2147467259"}},{"code":"Microsoft.Data.Mashup.ValueError.Key","detail":{"type":1,"value":"[Schema = \"Erp\", Item = \"ProdGrup\"]"}},{"code":"Microsoft.Data.Mashup.ValueError.Reason","detail":{"type":1,"value":"Expression.Error"}},{"code":"Microsoft.Data.Mashup.ValueError.Table","detail":{"type":1,"value":"#table({\"Name\", \"Data\", \"Schema\", \"Item\", \"Kind\"}, {})"}}],"exceptionCulprit":1}}} Table: dProductGroup. Cluster URIWABI-US-EAST2-redirect.analysis.windows.net Activity ID5c7699b0-7db4-42c7-a780-ac703d915f35 Request IDf6c90b28-4403-4ebe-827e-233ed7a57a89 Time2020-10-16 11:41:46Z

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
New Member

Turns out the issue was that the user account the gateway was installed on was not a sysadmin on SQL Server. Changed the creds there and it started working. No idea if changes were made to to credentials and prompted all this, or if it's not been sysadmin the entire time and the gateway just randomly decided to not be ok with that one day. 

Either way, it's resolved.
Thanks!

View solution in original post

2 REPLIES 2
Highlighted
Super User I
Super User I

@JimmieW The data gateway just had an update, did you try and update it to the latest version?

Highlighted
New Member

Turns out the issue was that the user account the gateway was installed on was not a sysadmin on SQL Server. Changed the creds there and it started working. No idea if changes were made to to credentials and prompted all this, or if it's not been sysadmin the entire time and the gateway just randomly decided to not be ok with that one day. 

Either way, it's resolved.
Thanks!

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors