cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Pete_Swansea
Frequent Visitor

Hyperlink to reports not working from within Word

I have an issue where I can't seem to link directly to a Power Bi report from a word document. If a member of staff clicks the hyperlink in word then they are taken to the Power Bi Sign in page (which after sign-in doesn't lead to the report).

If the link is copy and pasted into a browser, it works ok.

If the word document is PDF'd, the link works ok.
If the link is clicked within Excel (or teams or anywhere else), it works ok.

 

It is only when the link is clicked from within word that it doesn't seem to work.

 

Is there a reason why this may be, as we need to produced word documents with hyperlinks within them for staff.

14 REPLIES 14
jdavisona
Regular Visitor

Any update on this? I am also experiencing this issue.

Anonymous
Not applicable

I was having the same issue and found a solution: appending "&noSignUpCheck=1" to the end of the URL fixed it for me. The hyperlink then took me directly to the report rather than to a sign in page.

Thank you @Anonymous  that will be a huge improvement for our users 🙂

 

Does anyone know if there is a list of the system parameters that can be passed?

piyush_misra
Frequent Visitor

Yes - I also have the same issue. Any solution yet?

Hi,

 

I have found that when I use the link provided by Power BI when I update the app, that link works from within Word etc, but I still cannot link to specific reports within the app from Word.

 

Pete

v-lili6-msft
Community Support
Community Support

hi, @Pete_Swansea 

I have tested on my side, but not reproduce the issue.

First, For normal, if you want to share a private app to others,  you and others both need the Pro license.

If you have purchased Premium and add your content to Premium, then when you share the content, the receiver could be free user.

https://docs.microsoft.com/en-us/power-bi/service-free-vs-pro

https://docs.microsoft.com/en-us/power-bi/service-premium

Second, If you open the Hyperlink, and the account of power bi service in the browser is not the user, it will take to the Power Bi Sign in page.

For example:

click the Hyperlink in word beforeclick the Hyperlink in word beforeclick the Hyperlink in word afterclick the Hyperlink in word after

And also, I paste the link into a browser which the current account is not Shared by the browser.

It will be  are taken to the Power Bi Sign in page too.

3.JPG

 

Best Regards,

Lin

 

 

 

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

We still can't find a solution to this issue, is there any update?

The users in my business are experiencing the same issue. Some have Pro licenses and some do not. The report is housed in a premium workspace and is shared with them.

 

If the link is navigated through any other means that Word or Powerpoint the users are directed to the report. If they follow a hyperlink from Word or Powerpoint they are directed to the sign in page. 

 

Frustrating when we are creating user guides. Causes loss of trust in the service the business will be utilizing.

We continue to have this issue. The only work around we have found is to convert all Word documents to PDFs. It seems odd that we require 3rd party software to enable two Microsft products to communicate.

 

I would be interested to know if you ever find a solution.

Sorry, no fix, but we have exactly the same issue, so would love to see an answer. It's very frustrating!

Thanks for you're response.

 

I have a Pro License and have tested this with different users, some have a Pro Licence and some don't, both get the same issue.

The workspace is Premium.

 

If I place a link into word then I am directed as below:

 

Hyperlink.PNG

 

This happens irrelevant of user type.

 

If the same link is copy and pasted into a browser than the user see's the report as intended. Also, if the link is pasted anywhere else or the word document is PDF'd, then it works as intended.

 

This only occurs when clicking a hyperlink within word.

 

Thanks,

Pete

I'm getting the same issue with PowerPoint as well.

We have been testing. This error only seems to occur if the user has a browser open and is logged in. If the user is logged out, with no broswer windows open then the links works (it prompts the user to log in but then goes to the correct report).

 

Therefore if the user clicks a second link then they are not directed correctly, likewise if the user already has a browser windo open then the link does not work correctly.

 

As previously stated this only seems to occur in Word and PowerPoint.

 

 

Video of the issue here - https://vimeo.com/318177816

 

Shows having to sign in every time a link is clicked and if the user is already logged into Power BI they dont get directed to the correct app.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power BI October Update 2021.jpg

Power BI Release

Click here to read more about the October 2021 Release!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Teds Dev Camp Oct. 2021 768x460.jpg

Power BI Dev Camp - October 28th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!