cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper III
Helper III

Hierarchy slicer erroring after today's update

Hi all,

 

I have several reports that use the hierarchy slicer, which were all working fine for months until today. When you try to filter at any node of the hierarchy slicer, all other visuals error out with the "!" cannot display data.

 

I've found that this only impacts my reports in the Power BI service and Power BI embedded, but the desktop version of the report filters without errors.

 

I also noticed that if change the Empty Leaf setting to On (default), the filtering works again! However, I really like the ability to turn off the empty leafs as it is a better user experience. Has anyone else had issues after today's update to PBI service/Desktop? If you have reports with the attribute slicer, please test and let me know!

 

 @jppp - If you have any updates, please let me know as well. I really love the custom visual and use it for many clients. I'm also curious if there is support to pass through the of the hierarchy slicer (lowest chosen level) when using the new Drillthrough feature. It doesn't seem to pass the correct context to the drillthrough page.

 

Thanks!

 

1 ACCEPTED SOLUTION

Hi @Mardin,

 

The current version should not be giving blank visuals and can be forced to be used by manual clearing the browser cache.

 

 

-JP

View solution in original post

39 REPLIES 39
Frequent Visitor

My hierarchy Slicer went blank today in IE11. It was working fine yesterday. I tried clearing my cache and it still doesn't work.

 

It's showing up in Chrome and Power BI desktop. Can anyone help? All users in my company are using IE.

Hi @kwu ,

 

There is an issue with the HierarchySlicer and Internet Explorer and a fix is comming.

Please use another browser (Chrome, Firefox or Edge) as a workaround.

 

Thanks, Jan Pieter

Frequent Visitor

Hi @jppp ,

 

Same problem happens again today. The hierarchy slicer went blank in IE11 again. Any idea what happened? Will a fix be implemented soon? unfortunately, users in our company are using IE11 as the official browser here. Thanks.

 

 

Frequent Visitor

I can also confirm on IE11 the Hierarchy slicer is blank again.  Thought this was fixed not that long ago.  Works fine on Chrome.

Accidentally a wrong version of the HierarchySlicer has been released by Microsoft which is causing this behavior, but now the correct working version is available again.

 

-JP

Frequent Visitor

Hi @jppp ,

 

The hierarchy slicer is back to normal now. Thanks.

Advocate I
Advocate I

We can't click any fields in the hierarchy slicer whatsoever-- tried Chrome, IE, Edge. The only time it works is if we select a field in a hierarchy slicer already expanded.

 

 

Advocate I
Advocate I

Same issue here, works in Chrome but not in Internet Explorer. When I edit the report in IE11, the Hierarchy Slicer is even gone in the list with Visualizations. 

 

IE11

Version: 11.0.9600.18920

Update versions: 11.0.51 (KB4074736)

 

Please fix this asap, this sort of bugs puts the reputation of Power BI on the line in my organization...


Kind regards,

Robby 

Frequent Visitor

I also experience error with the Hierarchy Slicer in all our dashboards. It works fine in Desktop version, but not when you publish to Poweer BI services. I have tried to re-upload my dashboards and create a new hierarchy slicer, but nothing works. 😞

Community Champion
Community Champion

I'll piggyback here.  I'm also getting issues with this Slicer, but with how it draws.  It appears to draw all of the labels Right Justified.  Example below.
EDIT: Clarify this is Microsoft Edge

 

Correct Display / Current Display

Correct.PNGIncorrect.PNG

(I no longer have access to this account)

Contents of Hierarchy slicer is blank in Internet Explorer but works fine in Google Chrome.

Works fine in Power BI Desktop, but not in published reports which are accessed via the Power BI on Premises Data Gateway

There is an issue with IE11 causing the visual to be blank and there is a fix on its way.

 

Also in this new version there is a fix of the levels being right aligned.

 

@Ross73312: which version of Edge are you seeing this behavior?

I do not see this behavior in the latest version (17.17134)

 

@Sicilian: The internal selection method has changed with this version. Can you try resetting the current seelction of the slicer and try again? And if it is still not working, can you share an example with me?

 

@jppp I've tried deleting and re-adding the visual, and re-setting/clearing all selections. It doesn't matter which node I choose, it will always cause all other visuals to error out with "Cannoy display visual."

 

It works 100% as expected in the Desktop. It only works in PowerBI.com when I have the Empty Leaf Setting to ON, which will show all the Blanks at each level, but allows the filtering to work correctly. I also noticed the carrots/arrows are missing from certain root nodes. For example, the category with a 7 should have  > expander option pictured below. This is from Chrome.

 

Let me know what other details you need.

 

 

hierarchy error.PNG

@jpppToday the problem occurred again. For the option of not showing empty values, the filter corrupts the entire report. This problem occurs both in powerbi.com (IE11, Chrome) and Desktop.

 

Please check this problem 🙂 

Hi,

I am facing similar issue.Hierarchy slicer is not working today on desktop and service both.

It throws error on selection.

 

It was working fine earlier.

Kindly help.

 

 

@jpppToday the problem occurred again. For the option of not showing empty values, the filter corrupts the entire report. This problem occurs both in powerbi.com (IE11, Chrome) and Desktop.

 

Please check this problem 🙂 

@Sicilianis it possible to share a desktop file with me as I cannot reproduce this behavior?

@jppp - I sent you a message with a link to download the PBIX. Let me know if you have any issues accessing it.

 

@willnic - What are the settings of your report? When you click any node in the hierarchy slicer does it cause your visuals to error as well?

 

I only have the issue in PowerBI.com and Power BI embedded. My report is a direct query report, but I do get errors on the imported version as well.

@Sicilian I am live connected to a tabular model on PowerBI.com. If I don't have a hierarchy in the slicer (i.e. just one level) I can't click the slicer box whatsoever. If I do have a hieararchy in the slicer, the visuals throw an error when I click the top hierarchy, but visuals do work if I click the 2nd level hierarchy (more detailed hieararchy).

Interesting. Mine errors out the visuals no matter which node I click (in PowerBI.com). The Desktop version works without issues.

 

We will have 6+ hierarchy levels, so it would be very cumbersome to add 6 drop down filters for each level of the hierarchy. Then we have a second hierarchy with 6+ levels as well. 

 

Helpful resources

Announcements
secondImage

Congratulations!

We are excited to announce the Power BI Super Users!

Wave Release 2

Check out the updates in Power BI.

Overview of Power BI 2020 release wave 2!

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors