cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
LaineyJB
Advocate II
Advocate II

Google Analytics connector - refresh error in service

We have 3 reports that use the Power BI Google Analytics connector, and for the past few days they have been failing to refresh on the service. I am able to manually refresh the reports in Desktop without changing anything.

 

The error we're receiving is as follows:
The field 'errors' of the record wasn't found.. The exception was raised by the IDataReader interface. Please review the error message and provider documentation for further information and corrective action.

 

Sometimes there is a table name listed at the end, but it isn't the same one with each refresh. There are no fields called "errors" in any of the datasets. I know that the documentation on the connector says issues may arise when the Google Analytics API changes, but it doesn't look like the API has changed in a while. Has anyone else run into this error?

1 ACCEPTED SOLUTION
LaineyJB
Advocate II
Advocate II

As of 3pm Central, it appears that this issue has been resolved. Support had me refresh our reports and they all completed successfully. If you've tried refreshing since then and are still getting the error, I'd suggest submitting a separate ticket.

View solution in original post

14 REPLIES 14
LaineyJB
Advocate II
Advocate II

As of 3pm Central, it appears that this issue has been resolved. Support had me refresh our reports and they all completed successfully. If you've tried refreshing since then and are still getting the error, I'd suggest submitting a separate ticket.

View solution in original post

danxshap
Frequent Visitor

We're running into the same exact problem — it started on October 8th.

 

I opened a support ticket and highlighted this thread.

LaineyJB
Advocate II
Advocate II

As an update to anyone following this thread, I've submitted a ticket to support and they have their product team working on a solution. No ETA but they are aware of the issue.

LazyDave
New Member

We are also experiencing this issue - error indicates that either 'errors' or 'dimensions' fields couldnt be read by the IDataReader.

 

Refresh details look like this:

Something went wrong

There was an error when processing the data in the dataset.
Please try again later or contact support. If you contact support, please provide these details.
Hide details
Data source errorThe field 'errors' of the record wasn't found.. The exception was raised by the IDataReader interface. Please review the error message and provider documentation for further information and corrective action.
Cluster [DEACTED]
Activity [DEACTED]
Request [DEACTED]
Time2021-10-12 05:27:43Z
TorbenL
Advocate I
Advocate I

Same here. It works fine in the desktop, but we are hitting the exact same error for multiple reports in the service. All of them make use of the build in Power BI GA connector.

 

Best,

Torben

emuller
Frequent Visitor

I am also getting this error and can not find any reason for it. It also started Sunday October 10 2021. Refresh works just fine on desktop

arythedj
Helper I
Helper I

I am getting the same error since Sunday 10th Oct 2021.
Refresh is fine in Power BI Desktop.

wmayr
Regular Visitor

We are running into this issue as well. Works fine on Desktop but nothing in the service.

Burningsuit
Solution Sage
Solution Sage

Hi @LaineyJB 

Yes, it's not just you. I'm getting this same error on refreshing Google Analytics since yesterday, and know others who also have it. I don't have a fix (yet - I'm looking at it) but thought you should know that it seems more widespread than just your problem.

Hope this helps

Stuart

 

I'm encountering the same issue.

 

Connector: Google Analytics

Error: "The field 'errors' of the record wasn't found.. The exception was raised by the IDataReader interface. Please review the error message and provider documentation for further information and corrective action."

First Encountered: 10/10/2021, 6:31:07 AM Pacific Time

I am also experiencing this issue as well. Works fine on Desktop but nothing in the service.

Thanks for the reply, looks like there's quite a few others with this issue too. Have you submitted a ticket for this? We can go ahead and submit one if not.

We are also experiencing the same Google Analytics error messages in the Power BI Service. This is impacting production reports and so, I will submit a ticket for this issue today.

Hi @LaineyJB 

Go ahead and raise a ticket. I thought it was working this morning, but it seems to have stopped working again. Its not an issue for me, just an interest, so if you need it looked at quickly a ticket may help.

Burningsuit_0-1634045090754.png

Thanks

Stuart

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Kudoed Authors