cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
joel_gibby_csc
Helper I
Helper I

Getting DMTS_InvalidTenantKeyId when creating any new Gateway Data Source Connection

Hello,

 

When adding a new Gateway Data Source Connection, I'm getting an error code of DMTS_InvalidTenantKeyId.

 

I have a support request open. Googling the error code produces no results. I'll update this thread if any progress is made with Support. If an error code is exposed to an end user, it should be documented, no?

 

 

9 REPLIES 9
fsim
Advocate IV
Advocate IV

email I recieved from the support 1h ago:

Upon checking further from my end, we can see the similar cases from our most valued customer like you and I already escalated this case to our Product group team.

We got an update that these types of failures only be seen while creating a data source using gateways that got tenant migrated and also I checked with them and asked for ETA and they updated us current ETA for the fix will get deployed in end of next week.

Also we have a workaround till that time, this issue will happen only for a gateways that don’t have a TenantKey. So it’s better if you can add a new gateway then you can create data sources for that gateway.

nikshant
Frequent Visitor

Most importantly, it's to do with addressing the existing configuration of the gateway. Please reach out to the person who configured the gateway to check the status of the gateway on the server where it is installed.

The service account that's been used on configuring the gateway might have been moved/expired. Using the different service account will generally resolves the issue unless there's something else to check. But, make sure you've the Recovery Key before changing the service account. After you change the service account, you can take over the existing gateway and and try connecting the data sources again.

This is the most info I've seen yet, thanks for sharing. 

I can confirm the service account we're using is not disabled / locked out / expired, but I can certainly change the credential used to run the service and then change it back.

Thanks for the suggestion.

Also make sure your gateway version is upgraded too.

fsim
Advocate IV
Advocate IV

Same error here. impossible to add any new sources to the datagateway 😕

 

nikshant
Frequent Visitor

Ok, got the answer.

This is not any error happening on your side. It's the product bug from Microsoft side and currently they are working on it. ETA is not available but expected to get resolved soon.

 

There is not troubleshooting from the users end since it's not the issue from the user side.

jhangerssi
New Member

We are getting the same issue when creating new PBI gateways - see log output below
*Note - existing gateways work without issues using the same config

 

Unable to connect: We encountered an error while trying to connect to . Details: ""Hide details
Activity ID: c4309f65-b612-4afd-ba94-10d3e19e94da
Request ID: b0baa622-aa14-8e26-cf4e-432c9c03f3c3
Cluster URI: https://wabi-west-us-b-primary-redirect.analysis.windows.net/
Status code: 500
Error Code: DMTS_InvalidTenantKeyId
Time: Wed May 12 2021 22:07:11 GMT+0100 (British Summer Time)
Service version: 13.0.16039.63
Client version: 2105.1.06040-train

 

We have tried the fix suggested by Microsoft to clear global permissions locally on the PBI reports, then republish. This has not fixed the issue

What a strange troubleshooting step, seems like a waste of time and potential for errors / service interruption for reporting customers.

nikshant
Frequent Visitor

I am getting the same error on my side. Commenting here to follow up on this thread.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Solution Authors