cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
topdhi Frequent Visitor
Frequent Visitor

Fresh install on-premises GW does not work

Hi folks, I need some help.

 

I installed on-premise data gateway, installation went fine. I can see the GW is 'Online and good to go' on the data source page.

But when I try to add a datasource it will endup with an error Unable to connect: We encountered an error while trying to connect to [mySQLserver] Detail: There was an error in the data gateway.

 

Error Code: DM_GWPipeline_UnknownError

Underlaying error message: Error occured while decoding OAEP padding.

 

As it is suggested in the troubleshooting guide I went to EventLogs. Nothing is in the log, just service started info. So I googled a bit a found where the actual .log file is. And this is in it:

 

DM.EnterpriseGateway Error: 0 : 2017-03-28T10:23:17.7335891Z DM.EnterpriseGateway f86b2f41-e366-4c23-b97b-6d31966be0cb cc350022-c45b-9aaa-46bb-2dc300d451ed MGEC 8767f21a-649e-0772-1d9f-879afd68cda1 E1219B0E [DM.Pipeline.Common] Non-gateway exception encountered in activity scope: System.Security.Cryptography.CryptographicException: Error occurred while decoding OAEP padding.
   at System.Security.Cryptography.RSACryptoServiceProvider.DecryptKey(SafeKeyHandle pKeyContext, Byte[] pbEncryptedKey, Int32 cbEncryptedKey, Boolean fOAEP, ObjectHandleOnStack ohRetDecryptedKey)
   at System.Security.Cryptography.RSACryptoServiceProvider.Decrypt(Byte[] rgb, Boolean fOAEP)
   at Microsoft.PowerBI.DataMovement.CommonUtilities.AsymmetricKeyEncryptionHelper.Decrypt(String containerName, Byte[] data)
   at Microsoft.PowerBI.DataMovement.CommonUtilities.AsymmetricKeyEncryptionHelper.Decrypt(String ciphertext, String containerName)
   at Microsoft.PowerBI.DataMovement.Pipeline.GatewayCore.GatewayProcessor.<>c__DisplayClass42.<<EncryptCredentialsWithTestDataSourceConnection>b__41>d__44.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Microsoft.PowerBI.DataMovement.Pipeline.Common.Diagnostics.PipelineTelemetryService.<ExecuteInActivity>d__a`1.MoveNext()

 

I do not know what this is about. Can anybody give me some intructions ? I also restarted the server, no luck.

 

Help will be appreciated.

 

Tomas

 

 

1 REPLY 1
chrise Frequent Visitor
Frequent Visitor

Re: Fresh install on-premises GW does not work

Did you fix this?  I have a similar issue.