cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper III
Helper III

Filter not applying for different users on the same dataset

I was training users on Power BI last week. There were four of us all using the same data set under a shared workspace. 

We pulled Net Sales out into a card and it gave us a summation of Net Sales for the entire data set (as Expected).

When we went to filter by year (year to "Filters on this page"). Two of us were able to see sales filtered for the current year and the other two user were still seeing sales for the entire data set. I had them try to take it out and try again and they still had the same result.

They shared their screen with me so I was able to make sure they were doing it correctly.

I have had this happen before and I thought it was just a one time fluke so I didnt think anything of it. 

Our end users will not be able to trust the integrity of the information they are seeing. We would like to get this resolved before we do any more trainings. 

 

Thanks in advance for any insight on this.

4 REPLIES 4
Community Support
Community Support

Hi @tstackhouse

 

I agree with what suggested by @GilbertQ .Better check with the other 2 users to see whether the relationships and the direction in the relationship have seen set correctly.

 

 
Best Regards,
Kelly
Did I answer your question? Mark my post as a solution!

Thanks for the response @v-kelly-msft  and @GilbertQ !

 

I would agree that relationships would be the first place to look but this was in the service where the data set had already been created.  As well, the users were using the same data set so it doesnt make sense that 2 users are able to use the filer and 2 users were not.

Could it be something with specific users or version upgrades??

I would suggest talking to the dataset owner and making sure that it does have those required relationships?




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Super User II
Super User II

Hi there

Did you make sure that the relationships were in place between the tables?

It sounds to me as if there was a relationship missing.

I have never seen different data unless there is something different in the PBIX files.




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Helpful resources

Announcements
secondImage

Experience what’s next for Power BI

Join us for an in-depth look at the new Power BI features and capabilities at the free Microsoft Business Applications Launch Event.

secondImage

Power BI Women

Join our monthly meetings and learning sessions.

secondImage

Congratulations!

We are excited to announce the Power BI Super Users!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors