cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
FernandaT
New Member

Failed to update data source credentials: Web.Contents failed to get contents from '' (400): Bad Req

On the desktop the dashboard updates well, however when I publish it in power bi online, it has this error.

On the desktop I configured the web data source with the anonymous credential already.

 

FernandaT_0-1634584458688.png

 

3 REPLIES 3
FernandaT
New Member

Hi @GilbertQ 

Before using the value of auth_token and grant_type as a string, I changed it to a parameter. And the type of error has changed, this is the new request I am making:

When i update on the desktop it updates perfectly, but when going online it gives this problem.

 

FernandaT_1-1634844017083.png

 

FernandaT_3-1634844590639.png

 

In both none or organizational settings, it's giving the same error.

 

FernandaT_2-1634844376281.png

 

 

Hi @FernandaT 

 

Yeah I would expect that to work! Not sure why it is not working...





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

GilbertQ
Super User
Super User

Hi @FernandaT 

 

It appears that it is getting the error because it cannot find authenticate.

 

What happens if you change the security settings from Organizational to None?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Helpful resources

Announcements
Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!

UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!