cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
echo_chu
Frequent Visitor

Failed to Configure Correct Username/Password on Gateway Cluster

Hi Everyone, good afternoon.

 

I try to create a new data source via the company email account, and I have successfully configured the on-premises data gateway.

While when I add my data stored in the local folder to Gateway, the 'Windows username' and 'password' are invalid. Moreover, the same problem happened again when I was using Microsoft Flow to connect the local folder path.

 

Really thanks for your time and consideration, the error message text and screenshots are shown below:

@v-easonf-msft

 

Unable to connect: We encountered an error while trying to connect to . Details: "We could not register this data source for any gateway instances within this cluster. Please find more details below about specific errors for each gateway instance."Show details

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Re: Failed to Configure Correct Username/Password on Gateway Cluster

Hi, @echo_chu 

 

It seems from the screenshot that you can't access the data source due to the wrong credentials. Please make sure the 'Windows username' and 'Windows password' are correct. You might not know your UPN, and you might not be a domain admin. To find out the UPN for your account, run the following command from your workstation: whoami /upn. You may try to use domain\username as Windows username and setting 'Windows password' with the corresponding password.

 

Best Regards

Allan

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
Super User IV
Super User IV

Re: Failed to Configure Correct Username/Password on Gateway Cluster

First impression is that Python is not installed on any gateway.

---------------------------------------

Putting square pegs in round holes since 1972.

I have a NEW book! 
DAX Cookbook from Packt
Over 120 DAX Recipes!
Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!

echo_chu
Frequent Visitor

Re: Failed to Configure Correct Username/Password on Gateway Cluster

Yeah, I have not installed the python gateway path yet, while the main problem is that I do not know how to get the correct Windows Username and Password

Gateway1.PNG

 

@Greg_Deckler  Thanks for your timely reply!

Community Support
Community Support

Re: Failed to Configure Correct Username/Password on Gateway Cluster

Hi, @echo_chu 

 

It seems from the screenshot that you can't access the data source due to the wrong credentials. Please make sure the 'Windows username' and 'Windows password' are correct. You might not know your UPN, and you might not be a domain admin. To find out the UPN for your account, run the following command from your workstation: whoami /upn. You may try to use domain\username as Windows username and setting 'Windows password' with the corresponding password.

 

Best Regards

Allan

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

echo_chu
Frequent Visitor

Re: Failed to Configure Correct Username/Password on Gateway Cluster

thanks, it works

Here is the conclusion,

for windows 10 user,
the credential username could be found in the following method
1. Setting
2. Your Info
3. Click 'Sign in with a local account instead'
4. Click next steps till showing 'Windows Security'
5. The username domain/email is your credential username

Helpful resources

Announcements
Announcing the New Spanish Forum

Announcing the New Spanish Forum

Do you need help in Spanish? Check out our new Spanish community section.

April 2020 Community Highlights

April 2020 Community Highlights

Info on our Super Users, MBAS content and badges, and updates to our support articles. - Read the full Community Highlights.

MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.