cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
chiewchun
Frequent Visitor

Export to PDF not Respecting Filters Selection Applied

Hi,

 

I've encountered an issue this morning on one of my report where users selection on slicer were not exported to pdf. The export to pdf just defaulted to no selection. After enabling and disabling report options one by one, I found the issue to be the 'Persistent Filter' option.

 

It is weird that it is only happening today. I had the option enabled since the report was published a year ago and the export to pdf worked flawlessly since until today. I have disabled the option and the export to pdf now works. There maybe a bug with the 'Persisten Filter' option on PowerBI service. I have reminded my users to hit the reset filter button on the report everytime they access the report.

2 ACCEPTED SOLUTIONS
AnkitKukreja
Super User
Super User

Hi! @chiewchun 

 

The team is working on this issue and the fix will be deployed by end of this month.


The current workaround is to:

Select a dummy value on the filter options as the first choice and then select the actual filter value that they want the export to work with. Once they do this, they should be able to export with the desired filter value. This only applies when the customer has enabled the "Persistant filters" option on the PBIX file

 

If I have answered your question or solved your problem, please mark your post as solved.
If you liked my response, please consider giving it a thumbs up

Thanks,
Ankit Kukreja
www.linkedin.com/in/ankit-kukreja1904

View solution in original post

chiewchun
Frequent Visitor

Would like to reply that a fix was deployed for my situation and report is exporting fine right now.

View solution in original post

16 REPLIES 16
KiranHosakote
Helper IV
Helper IV

To export your Power BI report to PDF with filters and slicers applied (needs a Power BI Pro license), see https://medium.com/bi-helper/automated-distribution-of-power-bi-reports-and-dashboards-25fde6c68af0.

stayingdusty
Frequent Visitor

ticket submitted - this was a bug that has been fixed. all good now. thanks!

 

chiewchun
Frequent Visitor

Would like to reply that a fix was deployed for my situation and report is exporting fine right now.

AnkitKukreja
Super User
Super User

Hi! @chiewchun 

 

The team is working on this issue and the fix will be deployed by end of this month.


The current workaround is to:

Select a dummy value on the filter options as the first choice and then select the actual filter value that they want the export to work with. Once they do this, they should be able to export with the desired filter value. This only applies when the customer has enabled the "Persistant filters" option on the PBIX file

 

If I have answered your question or solved your problem, please mark your post as solved.
If you liked my response, please consider giving it a thumbs up

Thanks,
Ankit Kukreja
www.linkedin.com/in/ankit-kukreja1904

@AnkitKukreja  This is not the entire fix - if you have a single URL parameter... none of your manully added  filters are respected on export. 

Hi! @stayingdusty 

 

I didn't say this is a fix. This is a workaround, which might work and might not in some cases.

 

And I'm just sharing the info that I have. The fix will be available by next week, which means it would work as it used to previously.

 

If I have answered your question or solved your problem, please mark your post as solved.
If you liked my response, please consider giving it a thumbs up

Thanks,
Ankit Kukreja
www.linkedin.com/in/ankit-kukreja1904

Apologies - I honestly do appreciate the update - just wanted any MS employees that see this thread to not get confused that there are multiple issues, not just the persistent filters issue (there is also the export issue related to URL params.) 

 

Again - appreciate you sharing the info you have. 

mlong
Frequent Visitor

Experiencing the same issue with filters selected not being respected when exporting. The exported report defaults back to all the values regardless of selected filter even though the live Power BI report is being filtered correctly. Has a ticket been raised on this issue as the work around metioned above is not an option.

@mlong  - just so we're aware,

 

1. did you try the persistent filters troubleshooting?

 

2. are you passing URL filters?

Persistent filters is a work around but is causing a disruption in the day-to-day operations. As others have mentioned this was not an issue prior to 8/19.

A ticket is submitted to Microsoft with a link referencing this discussion.

Thanks everyone!



I've raised a ticket. For me, turning off persistent filter worked. @mlong , you may want to raise a separate ticket.

stayingdusty
Frequent Visitor

also, @chiewchun  did checking the box ( or unchecking the box) fix it for you (persistent filters option)? ...need to know what you meant by "disabling the option" so I can test as well. 

@stayingdusty I unchecked the persistent filter option on powerbi service and the export to pdf worked. I did enabled it again to test but it did not work, so I left it unchecked.

 

It is weird though as I did not have this issue before. I've already submitted a ticket to MS to investigate if it is a bug. In the meantime it's working for my report with persistent filter unchecked.

@chiewchun thanks for the quick reply!

 

I have toggled the "Don't allow end user to save filters on this report." and tested both ways to no affect. I think I might have a different (but related) defect:

 

Defect: *No* filter selections are respected on export if *any* URL filters are passed. 

 

To produce the defect:

  1. I go to a report via a URL that includes URL filters (i am aware that these do not work for export)
    1. Example: https://app.powerbi.com/groups/.../ReportSection?filter=Projects/Id eq 8
  2. The report loads correctly within PBI Online per the URL filter passed
  3. I manually select a filter option on a different field in the filters pane
  4. I export
    1. Result: The URL filters are not respected (this is expected) ✔️
    2. Result: The manually selected filter is not respected (this is a defect)

The work-around:

  1. I go to the report with no URL filters
  2. I manually select a filter option in the filters pane
  3. I export
  4. the manually selected filter option is respected

The work-around will not work for our users, I am just noting it here so others are aware. 

 

stayingdusty
Frequent Visitor

I am having same issue with my users... been working fine for a report published for months, but now when I test it, I select and apply an "all pages" filter selection, the report looks as it should within the PBI Online interface, until I export to PDF/PPT (same effect for both formats) where the filter selection is ignored. (I get all results)

AnkitKukreja
Super User
Super User

Hi! @chiewchun 

 

There was a bug long time back on this. It could be the same. I would advise you to raise a ticket to MS.

If I have answered your question or solved your problem, please mark your post as solved.
If you liked my response, please consider giving it a thumbs up

Thanks,
Ankit Kukreja
www.linkedin.com/in/ankit-kukreja1904

Helpful resources

Announcements
November 2022 Update

Check it Out!

Click here to read more about the November 2022 updates!

Microsoft 365 Conference â__ December 6-8, 2022

Microsoft 365 Conference - 06-08 December

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power BI Dev Camp Session 27

Ted's Dev Camp

This session walks through creating a new Azure AD B2C tenant and configuring it with user flows and custom policies.

Top Kudoed Authors