cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Errors while refreshing dataflow

Getting the following errror while refreshing Dataflows:

Error: The credentials provided for the PowerBI source are invalid. (Source at PowerBIInternal.).. RootActivityId = 5e7f6b7b-9988-48d6-8f69-69491f1f0f88.Param1 = The credentials provided for the PowerBI source are invalid. (Source at PowerBIInternal.) Request ID: c97c28f7-465a-fb40-11d9-9241c1689b64.

 

Nothing was changed in the Dataflow and the error started at midnight PST (9/16/2020).

6 REPLIES 6
Frequent Visitor

I have a severity A ticket outstanding. we began experiencing these issues on 10/09 with some DFs and now the whole lot have fallen over.

I'm not satisfied with the workaround as it will mean tearing up our architecture and cause us scheduling issues.

I really think the service status on the support page shouldn't read "No known issues: Power BI is running smoothly" - its not really is it?

Frequent Visitor

Same issue! 4 dataflows pulling from Salesforce and Excel, hourly refresh cadence, began failing yesterday at the 12:30AM scheduled refresh.

 

Spent all yesterday trying to troubleshoot, I was finally able to get everything running again, solution makes no sense but it's working for now. I hope this helps someone in the same predicament! 

 

My environment: 4 dataflows, the 1st pulls all the source data, the 3 following are Linked/Computed Entities. I am in a Premium workspace. Sources are Salesforce Objects & Excel. 

 

What I tried: Refreshing credentials, changing Privacy settings, switching gateways/gateway versions, importing the 1st dataflow as a new dataflow --- and it still failed. Finally, I took that source dataflow and imported it to a separate Premium Workspace - then it FINALLY refreshed!!! I was able to bring over the 3 reminaing/linked dataflows (importing JSON), and repoint their linked entities to the source dataflow (all in this separate Premium Workspace). The process was finicky and tedious but it finally worked. 1 Note - I did have to run it from the top (1st query kicks off 2, 3, & 4) in order for 2, 3 or 4 to refresh the first time around. 

 

The only thing different between the two workspaces is which capacity the workspace is assigned (we only have 2). The dataset consuming the dataflows is still in the orginal workspace and working fine. I asked our administator to move the second workspace to the same capacity as the orginal, and immediately the refresh failed. As soon as he switched the second workspace back to the other capacity, refreshes started working fine and ran hourly all night.

 

I cannot figure out what the issue is, my gut says this is related to metadata or authenication details stored in the metadata for this workspace? Perhaps a new capacity setting enabled by default? I would be great to find a solution, the dataflows still will not work in the original workspace and corresponding capacity

 

 

 

same issue, microsoft support replied with a workaround to disable the load, it did work but i need the the load enable because my dataset is using it. issue not resolved for me using that workaround. i really hope they resolve it asap 😞

Frequent Visitor

Same here!

Me too!

same issue too....

https://community.powerbi.com/t5/Service/dataflows-with-linked-entities-failing-to-refresh/m-p/13766...

 

We have contacted Microsoft and confirmed the issue.... In those conversations, we learned that the Power BI team is aware and working on it.. We did reiterate the severity of this issue.

Helpful resources

Announcements
secondImage

Happy New Year from Power BI

This is a must watch for a message from Power BI!

December Update

Check it Out!

Click here to read more about the December 2020 Updates!

Community Blog

Check it Out!

Click here to read the latest blog and learn more about contributing to the Power BI blog!

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Mark your calendars and join us for our next Power BI Dev Camp!.

Top Solution Authors
Top Kudoed Authors