cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Regular Visitor

Error with Data Refresh in Online Service for Web API Data Source

When initating a data refresh for a particular dataset in the online Power BI service, the following error is returned after roughly 2 hours:

 

{"error":{"code":"ModelRefresh_ShortMessage_ProcessingError","pbi.error":{"code":"ModelRefresh_ShortMessage_ProcessingError","parameters":{},"details":[{"code":"Message","detail":{"type":1,"value":"Timeout expired. The timeout period elapsed prior to completion of the operation."}}],"exceptionCulprit":1}}} Table: Table1.

 

The data refresh for this dataset consists of 6 queries:

  • 5 Web API calls (including both GET and POST methods) that receive JSONs and transform them into tables
    • 4 that return smaller "reference" tables (100s of rows with a dozen columns)
    • 1 that returns a larger table (~6000 rows with 100s of columns) - "Table1"
  • 1 merge query that is used to replace hexadecimal ID column headers in "Table1" with the matching names from one of the reference tables - "Table2"

The Web API query for "Table1" is set for a 3-hour timeout:

 

Source = Json.Document(Web.Contents(url & "ticket=" & apiTicket & "&project_id=" & projectID & "&step=filter&filter_id=" & filterID & "&details=some&include=custom_field_values",
[
Headers = [#"Content-Type" = "application/json"],
Content=Text.ToBinary(""),
Timeout=#duration(0,3,0,0)
])),

 

In the desktop version of Power BI, the data refresh takes roughly 45 minutes and completes successfully.

 

Using the same queries with a smaller data source (such that "Table1" would have ~250 rows instead of ~6000), the online service refreshes successfully.

 

Are there settings, either in the online service or in the desktop version, that could be adjusted to prevent this timeout error?

1 ACCEPTED SOLUTION

Accepted Solutions
Microsoft
Microsoft

Hi @Robert_T ,

 

You have touched the maximum refresh time of shared capacity. You can upgrade it to premium capacity. Or try to  optimize your data source to reduce data refresh.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,

Dedmon Dai

 

View solution in original post

2 REPLIES 2
Super User IV
Super User IV

@Robert_T , I doubt it still did not connect to database properly

in case you are using the gateway

https://docs.microsoft.com/en-us/power-bi/connect-data/service-gateway-onprem-tshoot

https://guyinacube.com/2016/09/21/troubleshooting-connectivity-tips/



Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!
Dashboard of My Blogs !! YouTube Channel !! Connect on Linkedin

Proud to be a Super User!

Microsoft
Microsoft

Hi @Robert_T ,

 

You have touched the maximum refresh time of shared capacity. You can upgrade it to premium capacity. Or try to  optimize your data source to reduce data refresh.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Best Regards,

Dedmon Dai

 

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors