Reply
Highlighted
Frequent Visitor
Posts: 4
Registered: ‎09-06-2017

Error when using Enterprise Gateway without AD to Connect on-prem SSAS tabular model.

I have created reports in Power BI desktop and published it on O365. I have installed the on-premise enterprise gateway and defined my gateway data source successfully to connect to my on-premise SSAS tabular model. Unfortunatily when openning the Power BI report on o365 I have an error. When looking in the gateway log I see the following error:

[1]Microsoft.PowerBI.DataMovement.Pipeline.Diagnostics.GatewayPipelineWrapperException: Substituted: AdomdErrorResponseException:<pi>Microsoft.AnalysisServices.AdomdClient.AdomdErrorResponseException: The following system error occurred:  We can't sign you in with this credential because your domain isn't available. Make sure your device is connected to your organization's network and try again. If you previously signed in on this device with another credential, you can sign in with that credential.

 

My computer is not in a domain and I do not have an AD. I use local Windows account to connect to my SSAS instance.

 

Can I configure the Enterprise Gateway to authenticate using the Windows local Account and not using an AD?

Super Contributor
Posts: 4,721
Registered: ‎07-08-2016

Re: Error when using Enterprise Gateway without AD to Connect on-prem SSAS tabular model.

@CosmeChris

 

No, the Analysis Services machine has to be joined to a domain.

You can take a look at this blog which talks about how authentication works with Analysis Services live connections.

 

Error when using Enterprise Gateway without AD to Connect on-prem SSAS tabular model_1.jpg

 

Best Regards,
Herbert