cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
XkBeXkBeM
Advocate I
Advocate I

Error refreshing Composite model live connection to Power BI dataset

I have a composite model that combines a direct query to a Power BI dataset in the service with imported data from Excel/dataflow. When I try to refresh in the service to re-import the non-live data I get a connection error related to the live model:

 

Processing error: COM error: Microsoft.ASWL.Service, Single sign-on (SSO) credential is not provided which is required to execute the current request.. A connection could not be made to the data source with the Name of '{"protocol":"analysis-services","address":{"server":"powerbi://api.powerbi.com/v1.0/myorg/[workspace]","database":"[model]"},"authentication":null,"query":null}'.
Cluster URI: WABI-EUROPE-NORTH-B-redirect.analysis.windows.net
Activity ID: 46425c40-2e48-4091-beaf-76a9e5e82614

 

I have re-checked the data source credentials and cloud data sources are allowed via this gateway. How can I get past this error and schedule a refresh of the model?

 

9 REPLIES 9
Quentin
Helper III
Helper III

Hello there, same problem over here, any news on the subject?
Thanks in advance!

This feature is still maturing, calculate table is not supported. One possible solution is to establish a link table between different live connected dataset and derive aggregation in new dataset. It's slow and inconvient but provides great feature aggregate different legacy data.

Santanumalik
Frequent Visitor

Hello, In my case I am trying to aggregate multiple data sources into one with live connection. So can't avoid calculated table (using UNION in this case) in the final dataset. Any work around? I have confirmed that refresh works if I remove the UNION table from final dataset. Any insight to the error and if anything can be set in tenant or capacity to make this working?

chasemccl
Frequent Visitor

I am getting the same error, with exactly the same set up as you. Are you able to refresh the dataset locally on Power BI Desktop?

Do you have any calculated tables in your composite model? 

I do, a date table.

I found that if I removed the calculated table it would refresh in the service without this SSO error. Still waiting to find out if this is a known limitation as from what I see in documentation this should work.

Awesome, good work to figure this out and thanks for letting me know! At least it's something we can work around for the time being.

 

This feature being so new, it seems like there are plenty of limitations, and also not much information on tips/tricks.

Yes it all processes successfully in desktop. Only the refresh in the service errors. 

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!