cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
XkBeXkBeM
Advocate II
Advocate II

Error refreshing Composite model live connection to Power BI dataset

I have a composite model that combines a direct query to a Power BI dataset in the service with imported data from Excel/dataflow. When I try to refresh in the service to re-import the non-live data I get a connection error related to the live model:

 

Processing error: COM error: Microsoft.ASWL.Service, Single sign-on (SSO) credential is not provided which is required to execute the current request.. A connection could not be made to the data source with the Name of '{"protocol":"analysis-services","address":{"server":"powerbi://api.powerbi.com/v1.0/myorg/[workspace]","database":"[model]"},"authentication":null,"query":null}'.
Cluster URI: WABI-EUROPE-NORTH-B-redirect.analysis.windows.net
Activity ID: 46425c40-2e48-4091-beaf-76a9e5e82614

 

I have re-checked the data source credentials and cloud data sources are allowed via this gateway. How can I get past this error and schedule a refresh of the model?

 

18 REPLIES 18
belvoir99
Helper II
Helper II

@XkBeXkBeM I have had the same issue (see other post in this thread). I think I have now found the 'answer'. See this page of documentation on Composite Models:

https://docs.microsoft.com/en-us/power-bi/transform-model/desktop-composite-models

 

Scroll down to 'Limitations and considerations'. There it states that you can't use Power BI datasets with composite models.

That is what I was trying to do. Perhaps you were also?


Possibly to answer other people's questions on this thread, I will be undertaking the following:

1. Connect direct to the dataflows that deliver content to the shared datasets.
2. Remove any relevant code out of the shared datasets and up into the dataflows.
3. Test like crazy to ensure my numbers are still correct.

I have a long tedious build ahead! 😒


belvoir99
Helper II
Helper II

Has anyone got an answer to this from Microsoft? I'm now stuck without a solution. I get exactly the same as above. See details below. Microsoft: a workaround and/or explanation would be fine, please! I need this for an important multinational client. 

I get an error message as follows when running a refresh in the Service. It works fine in the Desktop.

COM error: Microsoft.PowerBI.AS.ConnectionDetailsProvider, Single sign-on (SSO) credential is not provided which is required to execute the current request.. A connection could not be made to the data source with the Name of
'<pii>{"protocol":"analysis-services","address":{"server":"powerbi://api.powerbi.com/v1.0/myorg/DatasetNameHere","database":"DatasetNameHere"},"authentication":null,"query":null}</pii>'

I have 3 shared datasets joined together with a UNION calculated table joining them together. Without the UNION table, it refreshes fine - there is no credential error.
I have gutted the calculation down to 2 datasets and just one CALCULATE calculation but still I get the error. Only if I have literally no calculations in the UNION will it work.

Storage Mode is mixed, ie. it's a composite table due to 3 shared datasets loaded. 

 

 

 

jow_kinetic
Regular Visitor

I am facing the same issue. I have union tables on both date tables and dim tables. There is no issue to refresh on desktop but cannot pass the error on PowerBI service. Wish there are more documentations around this.

thomaska
Regular Visitor

Any solution on that? I am facing the same problem and i cannot remove the calculated tables. 

This requires a solution from the team as it looks that the problem is for a long time.

M_S
New Member

I am facing the same issue with the composite model. Has anyone encountered this problem and found a solution?

texmexdragon
Memorable Member
Memorable Member

I am facing the same issue has many of you.   I have a composite model.   I am then building another model (from that composite model).    I tried replicating the main model's date table using create new table because I wanted to test something, and I started getting this refresh error.   I deleted that calculated date table (the one I was trying to replicate, not the original one from the direct query table in the source model), and sure enough, my model refreshed perfectly.    They say the composite models are the way of the future...but man are they a headache when compared to the simplicity of a pure import model.

Agreed. At this point our org has stayed away from composite models, due to this issue and funky stuff happening with dates on graphs. 

Idadiz
Frequent Visitor

Hi,

have you found any solution to this yet? 
I need to combine the different datasets into one table and thus have a calculated one. But I need to be able to autorefresh the report.

Quentin
Helper III
Helper III

Hello there, same problem over here, any news on the subject?
Thanks in advance!

This feature is still maturing, calculate table is not supported. One possible solution is to establish a link table between different live connected dataset and derive aggregation in new dataset. It's slow and inconvient but provides great feature aggregate different legacy data.

Santanumalik
Frequent Visitor

Hello, In my case I am trying to aggregate multiple data sources into one with live connection. So can't avoid calculated table (using UNION in this case) in the final dataset. Any work around? I have confirmed that refresh works if I remove the UNION table from final dataset. Any insight to the error and if anything can be set in tenant or capacity to make this working?

chasemccl
Frequent Visitor

I am getting the same error, with exactly the same set up as you. Are you able to refresh the dataset locally on Power BI Desktop?

Do you have any calculated tables in your composite model? 

I do, a date table.

I found that if I removed the calculated table it would refresh in the service without this SSO error. Still waiting to find out if this is a known limitation as from what I see in documentation this should work.

Awesome, good work to figure this out and thanks for letting me know! At least it's something we can work around for the time being.

 

This feature being so new, it seems like there are plenty of limitations, and also not much information on tips/tricks.

Yes it all processes successfully in desktop. Only the refresh in the service errors. 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power BI October Update 2021.jpg

Power BI Release

Click here to read more about the October 2021 Release!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Teds Dev Camp Oct. 2021 768x460.jpg

Power BI Dev Camp - October 28th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!