cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Error Code: DMTS_PublishDatasourceToClusterErrorCode

Hi all,

 

I'm receiving the following error when trying to hook up an On-premises data gateway to SQL Server (text of error contained within spoiler). 

 

I'm able to connect to the SQL Server via ODBC. I've tried using both "Basic" and "Windows" authentification method. I've also tried to manually access the database with no issue and I've had no issues setting up a personal gateway, it just seems a regular on premises returns the Error Code: DMTS_PublishDatasourceToClusterErrorCode. Does anyone have anything that can help with this? 

 

Kind regards,

 

Jordan 

 

image.png 

Spoiler
Unable to connect: We encountered an error while trying to connect to . Details: "We could not register this data source for any gateway instances within this cluster. Please find more details below about specific errors for each gateway instance."Hide details Activity ID: e76ad1b0-384d-403b-b87a-186a23e4cde6 Request ID: d19779c9-9ce3-6880-4e31-41c40841a31e Cluster URI: https://wabi-uk-south-redirect.analysis.windows.net/ Status code: 400 Error Code: DMTS_PublishDatasourceToClusterErrorCode Time: Tue Jun 23 2020 17:05:04 GMT+0100 (British Summer Time) Service version: 13.0.13599.209 Client version: 2006.2.01600-train MSG-PowerBI-GW-01: There was an error in the data gateway. Underlying error message: The parameter is incorrect. DM_ErrorDetailNameCode_UnderlyingHResult: -2146893785

1 ACCEPTED SOLUTION
Anonymous
Not applicable

Hi @FMazurek,

 

I did eventually get this solved.

 

The underlying issue came down to an IT/Firewall blocker that needed to be fixed by our infrastructure team, as this wasn't a PBI or credential issue - they likely need to allow the gateway to connect.

 

Hopefully this helps!

 

Kind regards,

 

Jordan 

View solution in original post

3 REPLIES 3
FMazurek
New Member

Hi @Anonymous 

 

Did you solve this problem? What was the solution?

 

Thanks!

Anonymous
Not applicable

Hi @FMazurek,

 

I did eventually get this solved.

 

The underlying issue came down to an IT/Firewall blocker that needed to be fixed by our infrastructure team, as this wasn't a PBI or credential issue - they likely need to allow the gateway to connect.

 

Hopefully this helps!

 

Kind regards,

 

Jordan 

v-yingjl
Community Support
Community Support

Hi @Anonymous ,

Which gateway version you are using? I can connect to sql server successfully in my environment using gateway June 2020. Maybe you can update the gateway to the latest version to try to configure again.

 

Best Regards,
Yingjie Li

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
May 23 2022 epsiode 5 without aka link.jpg

The Power BI Community Show

Welcome to the Power BI Community Show! Jeroen ter Heerdt talks about the importance of Data Modeling.

charticulator_carousel_with_text (1).png

Charticulator Design Challenge

Put your data visualization and design skills to the test! This exciting challenge is happening now through May 31st!

Power BI Dev Camp Session 22 with aka link 768x460.jpg

Check it out!

Mark your calendars and join us on Thursday, May 26 at 11a PDT for a great session with Ted Pattison!

Power BI Release May 2022 768x460.png

Check it out!

Click here to read more about the May 2022 updates!

Top Solution Authors
Top Kudoed Authors