cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Enterprise gateway "cannot connect to the mashup data source"

Hi, everyone,

 

I'm having trouble trying to migrate my data sources to the enterprise gateway.

 

The sql server connections have connected with no issues, however, when I try to connect a Mysql database and an excel file, I'm having this following error:

 

Unable to connect: We encountered an error while trying to connect to \\msjdb\Other_data\DimDate.xlsx. Details: "Cannot connect to the mashup data source. See error details for more information."Hide details
Activity ID:b1981927-e3f7-198a-b1ba-15ba98c77480
Request ID:1763c05f-277e-7bc8-7c74-57b6bc65eb86
Cluster URI:https://wabi-north-europe-redirect.analysis.windows.net
Status code:400
Error Code:DM_GWPipeline_Gateway_MashupDataAccessError
Time:Mon Mar 14 2016 14:54:22 GMT+0200 (FLE Standard Time)
Version:13.0.800.645
Underlying error message:We're sorry, an error occurred during evaluation.
DM_ErrorDetailNameCode_UnderlyingHResult:-2147467259
Underlying error code:-2147467259

 

Any help would be appreciated as the error is not clear to me.

 

Thank you.

1 ACCEPTED SOLUTION
echofoxtrot
Advocate II
Advocate II

I've had the same issue and the fix for me was uninstalling the Personal Gateway or the Enterprise Gateway. I had both running and there seems to be a conflict if both programs are installed.

View solution in original post

36 REPLIES 36
vyurbonas
New Member

PROBLEM

My day started with error during refresh via gateway:

 

{"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"An error happened while reading data from the provider: 'Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).'"}},{"code":"DM_ErrorDetailNameCode_UnderlyingHResult","detail":{"type":1,"value":"-2147467259"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourceKind","detail":{"type":1,"value":"MySql"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourcePath" ...

 

I tried all recomendations above, nothing helped in the begining.

 

STEPS I DID TO SOLVE

  1. Refresh stopped working even from power bi desktop. Got error  
    1. I renewed to Power bi desktop [Version: 2.79.5768.721 64-bit (2020 m. kovas)]    (didn't help)
    2. Added OldGuids=true in  
      • Source = MySQL.Database("xxxxx", "dwhdb", [ReturnSingleDatabase=true,OldGuids=true])   (this solved me refresh in power bi desktop, but refresh via gateway was still failing)
  2. At this moment Refresh via gateway didn't complain about Guid, the error was 
    • {"error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","pbi.error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","parameters":{},"details":[],"exceptionCulprit":1}}} Table: Products Data

Finally I remembere doing mysql 8 config changes for ETL tools.

 

[mysqld]
sql_mode=''
character_set_server=utf8mb4
character_set_filesystem=utf8mb4
collation_server=utf8mb4_0900_ai_ci
#character-set-client-handshake=FALSE
init-connect = 'SET NAMES utf8mb4'
innodb_read_io_threads=8
innodb_write_io_threads=8
local_infile=1
disable_log_bin

 

What caused issue for me was character-set-client-handshake=FALSE. I commented it out and it started working again.

I also undone step removed OldGuids=true, which was no longer necessary. And all started working again.

 

CONCLUSION

For me it was caused by MySQL 8 character set configuration. So if you have issue - you may want to revisit your configs of the data source.

 

Mamerion
Frequent Visitor

same problem here.

updated the gateway to the latest i.e Sep 2018; refreshed the report in Desktop and re-published it on the Service, still getting the same error message.

referred to the log files on the server and found the follwoing

 

UserName: MyAdminAccount
MachineName: ServerName


EAD7B167 [DM.EnterpriseGateway] Starting On-premises data gateway service
[DM.GatewayCore] Setting thread pool worker threads = 300, min completion port threads = 300
9D1FD689 [DM.GatewayServiceHost] Starting direct query pool if necessary.
[DataMovement.PipeLine.MashupCommon] Mashup Container Pool DirectQueryPool created.
 [DM.GatewayServiceHost] Direct query pool created True.
[DM.GatewayServiceHost] Starting test connection pool if necessary.
[DataMovement.PipeLine.MashupCommon] Mashup Container Pool TestConnectionPool created.
[DM.GatewayServiceHost] Test connection pool created True.
[DataMovement.PipeLine.MashupCommon] Mashup Test Connection Settings - TestConnectionTimeout: 00:00:50.
[DataMovement.PipeLine.MashupCommon] Mashup Engine Container Settings - ContainerMaxCount: 6. ContainerMaxWorkingSet: 256MB. ContainerTimeToLive: 
[DM.GatewayServiceHost] MashupCustomConnectors = True
[DataMovement.PipeLine.MashupCommon] SetMashupConnectorsProviders: instantiate memory provider with extensions developed for gateway
[DataMovement.PipeLine.MashupCommon] Mashup extension file (R, powerbiextensions.r.mez) exists. Start loading.
[DataMovement.PipeLine.MashupCommon] Mashup extension file (Python, powerbiextensions.python.mez) exists. Start loading.
[DataMovement.PipeLine.MashupCommon] SetMashupConnectorsProviders: instantiate PowerBIExtensions assembly
[DataMovement.PipeLine.MashupCommon] SetMashupConnectorsProviders: instantiate filesystem provider at C:\Users\MyAdminAccount\Documents\Power BI Desktop\Custom Connectors, expanded: C:\Users\MyAdminAccount\Documents\Power BI Desktop\Custom Connectors
[DataMovement.PipeLine.MashupCommon] MashupLibraryProvider filesystem provider did not start. Reason: The directory name C:\Users\MyAdminAccount\Documents\Power BI Desktop\Custom Connectors is invalid.

I am not using any custom connector; so why it is set to True in Mashup engine?

 

I ended up un-installing and then re-installing the latest version of the gateway to overcome the issue.

Hi all,

 

I had a call with Microsoft, they asked me to put privacy level to PRIVATE in the desktop, re-publish, then set privacy = PRIVATE in the PBI online service too (in the gateway settings we're using).

 

It solved the issue.

 

Cheers,

 

F.

Hi All,

 

Require help on the similer kind of issue in my use case. Im using web api and SQL database to get the combination data out of both. The sql datasource works fine in gateway and when i use the web api with sql to get a dataset by invoking a function, the desktop refresh happens without any issue but when i publish the report to PowerBI service it gives me mash-up,privacy & data combination errors..

 

Both my SQL database & web url are configured in the gateway but the refresh fails. Bleow are the details.

 

Microsoft.Data.Mashup.MashupSecurityException.Reason:

PrivacyError

 

 

Function used : = (#"Port A" as any, #"Port B" as any) => let
Source = Table.FromColumns({Lines.FromBinary(Web.Contents("Text", [RelativePath="v1/Voyage?port=" & #"Port A" & "&port=" & #"Port B" & "&scaneca=true" & "&api_key=key"]))})
in
Source 

Ran into this issues when testing new dataflows feature. All scheduled refreshes in "My Workspace", whose tables were also in the "test" dataflow would fail. Reconfiguring service gateway privacy settings solved refresh failure issue.

Thanks @fhendrick - worked a treat!

leandros
Frequent Visitor

I am also getting the same error message.

 

My data sources: Dynamics 365, two Excel spreadsheets (not tables) in Sharepoint/One Drive for Business, and a web page.

 

As I understand it, it's only the web page that has me needing the gateway at all. In any case, I can set up all my connections in the gateway, and it seems satisfied with the credentials I provide (anonymous for the web page, OAuth for the others). But when it comes time for the schedule refresh, the gateway spins for a long time and then returns this error.

 

I have the on-premises gateway installed, and I've never had any other gateway installed on this machine (it's a virtual machine in AWS, set up specifically for this purpose).

 

Based on an earlier suggestion in this thread, I looked at my gateway logs. They're just line after line of "Pool cleaner connections removed," whatever that means.

arthastic
Advocate I
Advocate I

Hi guys!
I've found the solution for me.
I noticed that this problem appeared after adding the new server in our domain.
So I decided to use "gpupdate /force" from the cmd on the machine where DataGateway installed.
After group policy were updated the problem disappeared.

DanDeHaven
Frequent Visitor

Having this issue with an Enterprise Gateway. I removed a Personal Gateway (that had worked fine). The data sources in the Enterprise Gateway all connect without error yet the Datasets won't manually refresh or schedule refresh. Reports don't refresh either. I have to refresh everything from Desktop manually.

 

It's a definite show-stopper.

 

Any help from the technical team on this would much appreciated.

cfzini
Frequent Visitor

Hi everyone!

 

I'm facing a similar problem.

 

I'm conected with an SAP Bussiness Warehouse Server, in which the data is stored in Cubes (MDX).

 

After publishing my report, I had to stablish an On-Premisse Gateway, which after some headaches was conected

 

Now, when I try to mix the dimensions and measures from the cube, it gives me the same message: "cannot connect to the mashup data source".

 

This is a part of the message:

ID da atividade74425664-f642-46e9-bae1-2d2bca184e06
Solicitar ID87e821a7-97be-0982-04c4-87ddeae0d457
ID de correlação6bb57f90-49b1-31c7-872d-4334e1c87e12
Capturar.PNG
 
 
 
 
 
 
 
 
 
 
I've already uninstalled my Personal Gateway to check if it would work, but no, it didn't changed much.
JorgeDiego
Helper I
Helper I

Hello,

 

I´m also having the same issue. 

I´m trying to connect to a parvasive database through an ODBC (32 bits). I have tested that ODBC and it is working fine, but it is being impossible to use it in a new power bi data source. 

I have tried to add an SQL Server data source, and there is not problem in this case. 

 

Hope someone help me. 

Thanks in advance.

This is the error message that is being showed from Power BI:

 

No se puede conectarHemos detectado un error al intentar conectar con Dsn=ALFA0000001. Detalles: "No se puede conectar con el origen de datos del mashup. Para obtener más información, consulte los detalles del error."Ocultar detalles
Identificador de actividad: a1fd17e1-afba-4147-aa28-c8a2cc6d59ff
Identificador de la solicitud: a2cff37a-2f46-6d02-4dac-6a2e460323cb
URI de clúster: https://wabi-europe-north-b-redirect.analysis.windows.net
Código de estado: 400
Código de error: DM_GWPipeline_Gateway_MashupDataAccessError
Hora: Tue Dec 27 2016 11:59:32 GMT+0100 (Hora estándar romance)
Versión: 13.0.1700.866
Código de error subyacente: -2147467259
Mensaje de error subyacente: ODBC: ERROR [IM014] [Microsoft][Administrador de controladores ODBC] La arquitectura del DSN especificado no coincide entre el controlador y la aplicación.
DM_ErrorDetailNameCode_UnderlyingHResult: -2147467259
Microsoft.Data.Mashup.ValueError.DataSourceKind: Odbc
Microsoft.Data.Mashup.ValueError.DataSourcePath: dsn=ALFA0000001
Microsoft.Data.Mashup.ValueError.Reason: DataSource.Error

 

Anonymous
Not applicable

Hi,

 

Did someone find a resolution for this issue? please your feedbacks are more then indeed.

 

Thanks,

 

I wanted to just respond to this for anyone that might be having this issue going forward. I was receiving the same error, seemingly out of the blue on a report that was running and refreshing just fine. I verified that the base tables all contained data.

 

My connections are a few direct to a table and a few that I have a SQL query. I ran each of my queries in MS SQL to be sure all were running fine, and they were. I identified the table that was holding up the refresh in my desktop file, and tested making a small change to the syntax (removing distinct or removing order by). This seemed to have reestablished my connection and all connections refreshed just fine.

 

So now I know how to fix this issue, but the gap is why the connection was lost in the first place? Maybe something on the business side with the actual server I'm connecting to? I'm not sure. But if this happens to you, maybe try testing a small syntax change to your query and see if that works for you.

biki
Frequent Visitor

I had the same issue, but when i restarted the services of On-premises data gateway, it solved! 🙂 hope it helps!

leandros
Frequent Visitor

In my case, I ended up going nuclear on my solution. I pulled the web page table I was scraping into an Excel workbook and put that Excel workbook into Sharepoint with the others. Once everything was in the cloud (Dynamics 365 and Sharepoint), my dataset started updating on its own without the need for a gateway. 

 

I'd still like to figure out what was going on and why none of the suggested fixes were helping in my case, but I'll worry about that later. In this particular case for this particular client, I had banged my head against the wall enough.

I'm still faced with this issue. It started by installing the new gateway.

 

I then uninstalled the old personal gateway as well as the enterprise gateway that were installed on the same machine. The issue however still persists. I would like to roll back the installations, but I can't find the old personal gateway installer anywhere.

 

This is breaking the entire BI infrastructure in my company. Please, fix is needed urgently!

I opened a support issue on that one. Will let you know once resolved.

Did you finally have a solution for this issue? I have the same problem

TH
Regular Visitor

Did you solve the problem? Have the same problem at the moment:/

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Get Ready for Power BI Dev Camp

Microsoft named a Leader in The Forrester Wave

Microsoft received the highest score of any vendor in both the strategy and current offering categories.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.