cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
WouterVork
Frequent Visitor

Embedded dashboard not loading in Chrome

Hello all,

I have a PowerBI dashboard embedded into a website and for some reason I'm getting this error in the Chrome Browser:

WouterVork_1-1656339283927.png

In other browsers (I've tried Edge and Firefox) the dashboard works perfectly fine. I'm kind of lost on why this is happening, hopefully someone can provide some insight.

 

Regards,

Wouter

1 ACCEPTED SOLUTION
v-cazheng-msft
Community Support
Community Support

Hi @WouterVork,

 

If you only have this problem with specific browser, then this issue is caused by something related to the browser itself. When browser communicates with Power BI service for user data, cookie will be used to identify user and record individual’s browser history. Cookie will expire as well. When it happens, you will encounter some access issues. But it can be removed by clear cookie and try again. HTTP cookie - Wikipedia

 

@acbg @jcarville @aloire 

But if this issue takes place no matter what browser is used and clear cookie is not useful, you could check with your colleagues whether they will encounter any Embed issue like you.

If all of you have this problem, it is possible that your Power BI service admin has disabled the embed activities. Please ask the admin whether they disable the features like Publish to Web, Embed content in apps.

If this issue is specific on you, you need check whether your account is proper, whether you have required license to view the account and whether you have sufficient permission to view the content. For there are different kinds of embed strategies, you could refer corresponding official document to help you troubleshoot your problem.

 

Here are some official documents my help you.

Publish to web from Power BI - Power BI | Microsoft Docs

Embed a report in a secure portal or website - Power BI | Microsoft Docs

Embed a report web part in SharePoint Online - Power BI | Microsoft Docs

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly. If I misunderstand your needs or you still have problems on it, please feel free to let me know. Thanks a lot!

 

Best Regards,

Community Support Team _ Caiyun

View solution in original post

9 REPLIES 9
v-cazheng-msft
Community Support
Community Support

Hi @WouterVork,

 

If you only have this problem with specific browser, then this issue is caused by something related to the browser itself. When browser communicates with Power BI service for user data, cookie will be used to identify user and record individual’s browser history. Cookie will expire as well. When it happens, you will encounter some access issues. But it can be removed by clear cookie and try again. HTTP cookie - Wikipedia

 

@acbg @jcarville @aloire 

But if this issue takes place no matter what browser is used and clear cookie is not useful, you could check with your colleagues whether they will encounter any Embed issue like you.

If all of you have this problem, it is possible that your Power BI service admin has disabled the embed activities. Please ask the admin whether they disable the features like Publish to Web, Embed content in apps.

If this issue is specific on you, you need check whether your account is proper, whether you have required license to view the account and whether you have sufficient permission to view the content. For there are different kinds of embed strategies, you could refer corresponding official document to help you troubleshoot your problem.

 

Here are some official documents my help you.

Publish to web from Power BI - Power BI | Microsoft Docs

Embed a report in a secure portal or website - Power BI | Microsoft Docs

Embed a report web part in SharePoint Online - Power BI | Microsoft Docs

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly. If I misunderstand your needs or you still have problems on it, please feel free to let me know. Thanks a lot!

 

Best Regards,

Community Support Team _ Caiyun

Hi @v-cazheng-msft,

 

The issue @jcarville was having was caused by an update that had been deployed to the service a few days ago. I am a colleague of his, and we raised a support ticket on which it was confirmed that something had been broken and has since been fixed (as of yesterday) so the issue is now resolved for us.

 

Thanks, 

Richard

Thank you Richard, I confirm problem disappeared.

You support was quicker than mine 🙂

Hi @RCampbell,

 

That's great! Thanks for your reply!

 

Best Regards,

Community Support Team _ Caiyun

acbg
Resolver III
Resolver III

Same here and in North America

jcarville
Skilled Sharer
Skilled Sharer

Same issue in our North Europe tenant

aloire
Regular Visitor

Thank you, that is also what support suggested to me but that is not a solution...

WouterVork
Frequent Visitor

Apparently I had to allow third party cookies on the website and even then I had to delete my cookies on the app.powerbi.com website. After that, it worked. No clue what was going on.

aloire
Regular Visitor

same here.

 

Helpful resources

Announcements
August 1 episode 9_no_dates 768x460.jpg

The Power BI Community Show

Watch the playback when Priya Sathy and Charles Webb discuss Datamarts! Kelly also shares Power BI Community updates.

Power BI Dev Camp Session 24 without aka link and time 768x460.jpg

Ted's Dev Camp - July 28, 2022

Watch Session 24 of Ted's Dev Camp along with past sessions!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Top Solution Authors