cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Diverging data colours broken when .pbix is uploaded

Dear Community,

 

As this is my first post I have to start that I did use the search function using my message tags but it did not return a result related to my issue.

 

tl;dr Created visuals in BI Desktop. Uploaded .pbix to BI Online. BI Online did not copy the diverging data colours. Visual 'broken' in BI online. Looking for workaround.

 

I have created some nice visuals for my company using Power BI Desktop. This works nicely connecting to a SQL database from which I pull the relevant data. I am pulling turnover data and with a measure I calculate the percentage in/decrease compared to the previous year. In turn, I use this measure as a value for a filled/choropleth map to display in/decreases as green/red respectively (using diverging data colours where I set a value of -0.001, 0.001, and 0.05 to display colours for the percentages as red/green).

 

Recently we purchased some licenses for the Power BI online service and as such I uploaded my file to the online area expecting the visual to remain the same. I have come to find out that the diverging data colours option turns off and that my minimum, center, and maximum are removed.

Unfortunately I cannot post the data as it is sensitive data, but I was wondering if anybody is having the same issue and maybe found a workaround?

 

Thanks,
Kevin.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Frequent Visitor

Even when I try to create a new report in the online environment from the uploaded dataset it will display the diverging data colours only until exiting the report. Once you go back in they are "reset" as if you just created the visual. Seems like the settings are not being saved.

Can anybody else replicate this problem or do you already have it? Did you find a way to fix it? Let me know please.

View solution in original post

3 REPLIES 3
Highlighted
Frequent Visitor

Even when I try to create a new report in the online environment from the uploaded dataset it will display the diverging data colours only until exiting the report. Once you go back in they are "reset" as if you just created the visual. Seems like the settings are not being saved.

Can anybody else replicate this problem or do you already have it? Did you find a way to fix it? Let me know please.

View solution in original post

Highlighted

This appears to be a bug, several people have run into this, myself included and there does not appear to be a work around right now. Hopefully there is a fix soon. 

Highlighted
Frequent Visitor

Checked in this morning to update my reports and was pleased to see the diverging data colours are back! Topic marked as solved.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors