cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Direct Query in Service not refreshing the visual's data, works fine in desktop

Hi All,

 

I have created a report with Direct query. In desktop the refresh works fine. I published it to service. When I refresh the visual manually it only updates the last refresh time but the data of the visual does not update. I checked everything. The report shows the gateway is online, the data source is online but no idea why it does not refreshes and updates the data. Please help me with the resolution.

I am using November 2018 desktop version.

6 REPLIES 6
Community Support Team
Community Support Team

Re: Direct Query in Service not refreshing the visual's data, works fine in desktop

Hi shiv4422,

 

Does this issue happens on all of the datasource in your gateway cluster? Please update your data gateway to the lastest version and check again.

 

Regards,

Jimmy Tao

Anonymous
Not applicable

Re: Direct Query in Service not refreshing the visual's data, works fine in desktop

Thanks, Jimmy for the reply.

It is happening randomly for other reports too. But many reports work fine.

I will try the solution you have suggested and update if it works.

Anonymous
Not applicable

Re: Direct Query in Service not refreshing the visual's data, works fine in desktop

Jimmy, I am sorry I missed your point about Data Sources. No, it is not happening with all the data sources in my gateway and even I am using the same data source in other report it is working fine and refreshing without any issue. I restarted the gateway and then tried to refresh the report, still it is not updating the data only the last refresh date and time changes.

Community Support Team
Community Support Team

Re: Direct Query in Service not refreshing the visual's data, works fine in desktop

Hi shiv4422,

 

Have you updated on-premises data gateway to the lastest version?

 

Regards,

Jimmy Tao

Highlighted
MarcioL Regular Visitor
Regular Visitor

Re: Direct Query in Service not refreshing the visual's data, works fine in desktop

Did you get a solution for this? 

 

When I publish a report it updates the data but not the visuals. Where this what you have experienced?

Anonymous
Not applicable

Re: Direct Query in Service not refreshing the visual's data, works fine in desktop

@MarcioL Not yet, I have opened a support ticket with Microsoft to resolve this issue.

In my case, nothing refreshes. It just shows 'Last refresh successfully completed'.

Helpful resources

Announcements
Community Kudopalooza

Win Power BI Swag with Community Kudopalooza!

Each week, complete activities and be qualified in the drawing for cool Power BI Swag.

Summit North America

Power Platform Summit North America

Register by September 5 to save $200

Virtual Launch Event

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

MBAS Gallery

Watch Sessions On Demand!

Continue your learning in our online communities.

Top Kudoed Authors
Users Online
Currently online: 430 members 4,253 guests
Please welcome our newest community members: